summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alan Alberghini <414N@slacky.it>2023-07-28 20:28:30 +0900
committer Andrew Clemons <andrew.clemons@gmail.com>2023-07-28 21:02:47 +0900
commit594b69fb89de427383205a96d570046e6a6e8591 (patch)
treea6e70bd76bc7006e377f170b06742a4291837214
parent64ceae51016d32e272322454c004809817bc92ca (diff)
downloadslackbuilds-594b69fb89de427383205a96d570046e6a6e8591.tar.gz
slackbuilds-594b69fb89de427383205a96d570046e6a6e8591.tar.xz
libraries/terminator: Updated for version 2.1.3.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
-rw-r--r--libraries/terminator/README5
-rw-r--r--libraries/terminator/doinst.sh9
-rw-r--r--libraries/terminator/slack-desc19
-rw-r--r--libraries/terminator/terminator.SlackBuild123
-rw-r--r--libraries/terminator/terminator.info10
5 files changed, 166 insertions, 0 deletions
diff --git a/libraries/terminator/README b/libraries/terminator/README
new file mode 100644
index 0000000000..59d346e0c1
--- /dev/null
+++ b/libraries/terminator/README
@@ -0,0 +1,5 @@
+The goal of this project is to produce a useful tool for arranging
+terminals. It is inspired by programs such as gnome-multi-term,
+quadkonsole, etc. in that the main focus is arranging terminals in
+grids (tabs is the most common default method, which Terminator also
+supports).
diff --git a/libraries/terminator/doinst.sh b/libraries/terminator/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/libraries/terminator/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/libraries/terminator/slack-desc b/libraries/terminator/slack-desc
new file mode 100644
index 0000000000..e0ba1b78bf
--- /dev/null
+++ b/libraries/terminator/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+terminator: terminator (multiple terminals in one window)
+terminator:
+terminator: The goal of this project is to produce a useful tool for arranging
+terminator: terminals. It is inspired by programs such as gnome-multi-term,
+terminator: quadkonsole, etc. in that the main focus is arranging terminals in
+terminator: grids (tabs is the most common default method, which Terminator also
+terminator: supports).
+terminator:
+terminator: Homepage: https://launchpad.net/terminator/
+terminator:
+terminator:
diff --git a/libraries/terminator/terminator.SlackBuild b/libraries/terminator/terminator.SlackBuild
new file mode 100644
index 0000000000..e8f7c5a953
--- /dev/null
+++ b/libraries/terminator/terminator.SlackBuild
@@ -0,0 +1,123 @@
+#!/bin/bash
+
+# Slackware build script for terminator
+
+# Copyright 2016 Alan Alberghini <414N@slacky.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Build history:
+#
+# 1 - Initial release.
+# 20120206 - Updated for version 0.96
+# 20120916 - Removed icon-theme.cache from the package
+# 20130530 - Updated for version 0.97
+# 20160625 - Updated for version 0.98 (thanks to Andrzej Telszewski)
+# 20161126 - Updated for version 1.0
+# 20230507 - Updated for version 2.1.3
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=terminator
+VERSION=${VERSION:-2.1.3}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="INSTALL.md AUTHORS COPYING RELEASE.md README.md CHANGELOG.md CHANGELOG.legacy.txt TRANSLATION.md"
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Adjust doc location.
+sed -i "s|'share', 'doc', 'terminator'|'doc', '$PRGNAM-$VERSION'|g" setup.py
+sed -i "s|'share', 'doc', 'terminator'|'doc', '$PRGNAM-$VERSION'|g" terminatorlib/util.py
+# Adjust man location.
+sed -i "s|share/man|man|g" setup.py
+
+CFLAGS=$SLKCFLAGS \
+python3 setup.py --no-user-cfg install --prefix=/usr --root=$PKG
+
+rm -f $PKG/usr/doc/$PRGNAM-$VERSION/apidoc/.buildinfo
+rm -f $PKG/usr/doc/$PRGNAM-$VERSION/html/.buildinfo
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ $DOCS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/terminator/terminator.info b/libraries/terminator/terminator.info
new file mode 100644
index 0000000000..3e84c51471
--- /dev/null
+++ b/libraries/terminator/terminator.info
@@ -0,0 +1,10 @@
+PRGNAM="terminator"
+VERSION="2.1.3"
+HOMEPAGE="https://github.com/gnome-terminator/terminator"
+DOWNLOAD="https://github.com/gnome-terminator/terminator/releases/download/v2.1.3/terminator-2.1.3.tar.gz"
+MD5SUM="c15ed0329bd324fb3f0c59a88650780f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-pytest-runner python3-psutil configobj"
+MAINTAINER="Alan Alberghini"
+EMAIL="414N@slacky.it"