summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundyat>2023-07-28 20:28:23 +0900
committer Andrew Clemons <andrew.clemons@gmail.com>2023-07-28 21:02:44 +0900
commit7c7e93a09243be01b88d026a54be1fef59d3e6a4 (patch)
treea290b6ee4b76429cbd5e264a13afbb2a14cb58da
parente9ac7567b402520350a78254a39a37d3798fb982 (diff)
downloadslackbuilds-7c7e93a09243be01b88d026a54be1fef59d3e6a4.tar.gz
slackbuilds-7c7e93a09243be01b88d026a54be1fef59d3e6a4.tar.xz
libraries/xattr: Updated for version 0.10.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
-rw-r--r--libraries/xattr/README15
-rw-r--r--libraries/xattr/slack-desc19
-rw-r--r--libraries/xattr/xattr.SlackBuild98
-rw-r--r--libraries/xattr/xattr.info10
4 files changed, 142 insertions, 0 deletions
diff --git a/libraries/xattr/README b/libraries/xattr/README
new file mode 100644
index 0000000000..c8a6c60329
--- /dev/null
+++ b/libraries/xattr/README
@@ -0,0 +1,15 @@
+xattr is a Python wrapper for extended filesystem attributes.
+
+xattr also ships with an xattr command line tool for viewing and
+editing extended filesystem attributes. On platforms that support or
+ship with the attr package, you may prefer to use the getfattr and
+setfattr command line tools from the attr package.
+
+Extended attributes extend the basic attributes of files and
+directories in the file system. They are stored as name:data pairs
+associated with file system objects (files, directories, symlinks,
+etc).
+
+Extended attributes are currently only available on Darwin 8.0+ (Mac
+OS X 10.4) and Linux 2.6+. Experimental support is included for Solaris
+and FreeBSD).
diff --git a/libraries/xattr/slack-desc b/libraries/xattr/slack-desc
new file mode 100644
index 0000000000..21ed0bff7b
--- /dev/null
+++ b/libraries/xattr/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+xattr: xattr (Python wrapper for extended file system attributes)
+xattr:
+xattr: xattr is a a Python wrapper which gives access to the
+xattr: extended attributes for filesystem objects available in some
+xattr: operating systems.
+xattr:
+xattr:
+xattr:
+xattr: Homepage: https://github.com/xattr/xattr
+xattr:
+xattr:
diff --git a/libraries/xattr/xattr.SlackBuild b/libraries/xattr/xattr.SlackBuild
new file mode 100644
index 0000000000..b0c112d82a
--- /dev/null
+++ b/libraries/xattr/xattr.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for pyxattr
+# Copyright 2022-2023 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Updated for version: v0.10.1 July 2023
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=xattr
+VERSION=${VERSION:-0.10.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf "$PRGNAM"-$VERSION
+tar xvf $CWD/"$PRGNAM"-$VERSION.tar.gz
+cd "$PRGNAM"-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+export CC="gcc $SLKCFLAGS $(pkg-config --cflags talloc)"
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/xattr/xattr.info b/libraries/xattr/xattr.info
new file mode 100644
index 0000000000..255199d8f1
--- /dev/null
+++ b/libraries/xattr/xattr.info
@@ -0,0 +1,10 @@
+PRGNAM="xattr"
+VERSION="0.10.1"
+HOMEPAGE="https://github.com/xattr/xattr"
+DOWNLOAD="https://github.com/xattr/xattr/archive/refs/tags/v0.10.1/xattr-0.10.1.tar.gz"
+MD5SUM="cc89a45aa1abc26cb1c4cfc164fe5239"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"