summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2024-04-16 16:18:22 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-20 21:14:39 +0700
commit479e9942b78838a5af08ef5cf16fa9602f77d934 (patch)
treeefeaacccd349eb408cdf8650b922045ab92d284d
parent8c905ecc13f26c72b70cbe60034ff69409989a54 (diff)
downloadslackbuilds-479e9942b78838a5af08ef5cf16fa9602f77d934.tar.gz
slackbuilds-479e9942b78838a5af08ef5cf16fa9602f77d934.tar.xz
system/ded: Fix build.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/ded/ded.SlackBuild62
-rw-r--r--system/ded/ded.info8
2 files changed, 10 insertions, 60 deletions
diff --git a/system/ded/ded.SlackBuild b/system/ded/ded.SlackBuild
index 3b2ded4ad8..a8b24da3c3 100644
--- a/system/ded/ded.SlackBuild
+++ b/system/ded/ded.SlackBuild
@@ -10,6 +10,8 @@
# This build script was written from scratch for 14.1, without referring
# to the old script.
+# 20240416 bkw: this fucking thing has been broken for ages. fix it
+# by breaking td_lib out into a separate build.
# 20221227 bkw: updated for 20221011 release
# 20210220 bkw: updated for 20210110. get rid of configure patch, found
# a better way to disable the long filename test.
@@ -69,65 +71,15 @@ fi
set -e
-# not going to make td_lib a separate package. If anyone's packaging up any
-# of the (very few) apps that use td_lib, let them list ded as a dependency.
-LIBNAM=td_lib
-LIBVER=${LIBVER:-$VERSION}
-
-# build everything here so it's easy to clean up after
-BUILDDIR=$TMP/$PRGNAM-build
-
-rm -rf $PKG $BUILDDIR
-mkdir -p $BUILDDIR $PKG $OUTPUT
-
-cd $BUILDDIR
-rm -rf $LIBNAM-$LIBVER
-tar xvf $CWD/$LIBNAM-$LIBVER.tgz
-cd $LIBNAM-$LIBVER
-chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-
-# "checking for long filenames" wants to create files in /usr/lib and
-# /var/lib. Violates the principle of least surprise: users don't expect
-# configure scripts (or SlackBuilds) to touch their system directories.
-
-# This *should* work, but doesn't, I guess because configure.in is too old.
-#sed -i '/^AC_SYS_LONG_FILE_NAMES/d' configure.in
-#autoreconf -i
-
-# It turns out we can force it in the environment.
-ac_cv_sys_long_file_names="set" \
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --build=$ARCH-slackware-linux
-
-# NB: the -j1's are necessary, even on 'make install'.
-make -j1
-
-# actually, don't really need to make install, ded's configure will find
-# the static lib just fine, but there do exist other apps that use td_lib
-# so we'll include it in the package too. Upstream doesn't let us build
-# it as a shared lib.
-make -j1 install DESTDIR=$PKG
-
-# let's include the td_lib docs
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/$LIBNAM-$LIBVER
-cp -a CHANGES COPYING README $PKG/usr/doc/$PRGNAM-$VERSION/$LIBNAM-$LIBVER
-
-cd $BUILDDIR
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/system/ded/ded.info b/system/ded/ded.info
index 8a00095ac9..4949cc723f 100644
--- a/system/ded/ded.info
+++ b/system/ded/ded.info
@@ -1,12 +1,10 @@
PRGNAM="ded"
VERSION="20230122"
HOMEPAGE="http://invisible-island.net/ded/"
-DOWNLOAD="https://invisible-mirror.net/archives/ded/ded-20230122.tgz \
- https://invisible-mirror.net/archives/ded/td_lib-20230122.tgz"
-MD5SUM="d44b731ad16c7bcf6efeca7dbce4a885 \
- bb6d9f756b77e2c5eaa1260a3f98bd0b"
+DOWNLOAD="https://invisible-mirror.net/archives/ded/ded-20230122.tgz"
+MD5SUM="d44b731ad16c7bcf6efeca7dbce4a885"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="td_lib"
MAINTAINER="B. Watson"
EMAIL="urchlay@slackware.uk"