summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python3-pandas/python3-pandas.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/python/python3-pandas/python3-pandas.SlackBuild b/python/python3-pandas/python3-pandas.SlackBuild
index 33a8406941..daa7810213 100644
--- a/python/python3-pandas/python3-pandas.SlackBuild
+++ b/python/python3-pandas/python3-pandas.SlackBuild
@@ -73,7 +73,8 @@ sed -i 's/meson-python==/meson-python>=/' pyproject.toml
sed -i 's/meson==/meson>=/' pyproject.toml
# needs newer meson
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
# cannot build sdist, specify just wheel
python3 -m build --wheel --no-isolation