summaryrefslogtreecommitdiffstats
path: root/python/python3-joblib/python3-joblib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-joblib/python3-joblib.SlackBuild')
-rw-r--r--python/python3-joblib/python3-joblib.SlackBuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/python/python3-joblib/python3-joblib.SlackBuild b/python/python3-joblib/python3-joblib.SlackBuild
index f521684d5c..0d9f19d1c3 100644
--- a/python/python3-joblib/python3-joblib.SlackBuild
+++ b/python/python3-joblib/python3-joblib.SlackBuild
@@ -4,7 +4,7 @@
# Copyright 2019-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# Copyright 2022 Isaac Yu <isaacyu@protonmail.com>
-# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-joblib
SRCNAM=joblib
-VERSION=${VERSION:-1.3.2}
+VERSION=${VERSION:-1.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -70,6 +70,13 @@ find -L . \
PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
export PYTHONPATH=/opt/python$PYVER/site-packages/
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir "$PKG" dist/*.whl