summaryrefslogtreecommitdiffstats
path: root/libreoffice/build/libreoffice44.SlackBuild
diff options
context:
space:
mode:
author Eric Hameleers <alien@slackware.com>2015-07-01 23:30:00 +0000
committer Eric Hameleers <alien@slackware.com>2015-07-01 23:30:00 +0000
commit0644de134251e13b44312f65849e6c31dedeeecd (patch)
tree921dee28ee0724c8fe7249732c1807d4d2919475 /libreoffice/build/libreoffice44.SlackBuild
parent041e1463adef7a32080261a581533d1aa3b2a344 (diff)
downloadasb-0644de134251e13b44312f65849e6c31dedeeecd.tar.gz
asb-0644de134251e13b44312f65849e6c31dedeeecd.tar.xz
libreoffice44: updated to 4.4.4.3
Diffstat (limited to 'libreoffice/build/libreoffice44.SlackBuild')
-rwxr-xr-xlibreoffice/build/libreoffice44.SlackBuild46
1 files changed, 25 insertions, 21 deletions
diff --git a/libreoffice/build/libreoffice44.SlackBuild b/libreoffice/build/libreoffice44.SlackBuild
index a98e8266..896743c6 100755
--- a/libreoffice/build/libreoffice44.SlackBuild
+++ b/libreoffice/build/libreoffice44.SlackBuild
@@ -197,6 +197,8 @@
# * Update.
# 4.4.3-1: 23/apr/2015 by Eric Hameleers <alien@slackware.com>
# * Update.
+# 4.4.4-1: 02/jul/2015 by Eric Hameleers <alien@slackware.com>
+# * Update.
#
# Run 'sh libreoffice.SlackBuild' to build a Slackware package.
# The package (.txz) and .txt file as well as build logs are created in /tmp .
@@ -226,8 +228,8 @@ TAG=${TAG:-alien}
#SRCVER=${SRCVER:-HEAD}
#SRCVER=${SRCVER:-3.3.0.4}
-SRCVER=${SRCVER:-4.4.3}
-SUBVER=".1"
+SRCVER=${SRCVER:-4.4.4}
+SUBVER=".3"
PKG_SUBVER=""
# How many tarballs does this release consist of:
@@ -340,8 +342,8 @@ SRCURL[5]="http://cgit.freedesktop.org/libreoffice/core/plain/Makefile.fetch?id=
# Lots of tarballs of which I am not sure which one are really needed...
#
-# --- Start of section generated by gensrc.sh ---
-# External sources for libreoffice-4.4.3.1
+# --- Start of section generated by gensrc_lo44.sh ---
+# External sources for libreoffice-4.4.4.3
SOURCE[6]="$SRCDIR/sources44/185d60944ea767075d27247c3162b3bc-unowinreg.dll"
SRCURL[6]="http://dev-www.libreoffice.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll"
@@ -658,7 +660,7 @@ SRCURL[109]="http://dev-www.libreoffice.org/src/a7983f859eafb2677d7ff386a023bc40
SOURCE[110]="$SRCDIR/sources44/zlib-1.2.8.tar.gz"
SRCURL[110]="http://dev-www.libreoffice.org/src/zlib-1.2.8.tar.gz"
-# --- End of section generated by gensrc.sh ---
+# --- End of section generated by gensrc_lo44.sh ---
# Use the src_checkout() function if no downloadable tarball exists.
# This function checks out sources from SVN/CVS and creates a tarball of them.
@@ -865,17 +867,6 @@ echo Building ...
# Apply our own (borrowed) patches.
if [ "$P1" != "--oldbuild" ]; then
touch $OUTPUT/patch-$PRGNAM.log
- ## Add internal copies of Google's Carlito and Caladea fonts:
- ## (for 4.3.0 I expect that people install separate font packages instead)
- #cat $SRCDIR/patches/libreoffice.crosextra_fonts.patch | patch -p1 --verbose \
- # 2>&1 | tee -a $OUTPUT/patch-$PRGNAM.log
- ## Fix bug on KDE where application freezes:
- ## (fixed in 4.3.0)
- #cat $SRCDIR/patches/libreoffice.kde_qt_sessionmanager.patch \
- # | patch -p1 --verbose 2>&1 | tee -a $OUTPUT/patch-$PRGNAM.log
- ## Fix building with internal harfbuzz:
- #cat $SRCDIR/patches/libreoffice.harfbuzz.patch \
- # | patch -p1 --verbose 2>&1 | tee -a $OUTPUT/patch-$PRGNAM.log
# Remove failing unit test:
cat $SRCDIR/patches/libreoffice.failing_unittest.patch \
| patch -p1 --verbose 2>&1 | tee -a $OUTPUT/patch-$PRGNAM.log
@@ -901,6 +892,13 @@ else
KDEOPTS="--disable-kde4"
fi
+# Determine whether we will use gstreamer 0,10 or 1.0:
+if /usr/bin/pkg-config --exists gstreamer-1.0 ; then
+ GSTOPTS="--disable-gstreamer-0-10 --enable-gstreamer-1-0"
+else
+ GSTOPTS="--enable-gstreamer-0-10 --disable-gstreamer-1-0"
+fi
+
# Make it install into proper directories:
export OOInBase="/usr/lib${LIBDIRSUFFIX}/libreoffice"
export OOInstall="/usr/lib${LIBDIRSUFFIX}/libreoffice"
@@ -945,8 +943,13 @@ case "$ARCH" in
ARCHOPTS=" " ;;
esac
-#enable_pam=no \
-./autogen.sh \
+# Never hurts:
+aclocal -I m4
+autoconf -v
+
+# Do not run autogen.sh on make:
+touch autogen.lastrun
+./configure \
--prefix=/usr \
--docdir=/usr/doc/$PRGNAM-${LOVER}${VERSION}${PKG_SUBVER} \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@@ -959,12 +962,12 @@ esac
--with-package-format="archive installed" \
--with-vendor="Slackware Team ($PACKAGER)" \
${GITOPTS} \
+ ${GSTOPTS} \
${KDEOPTS} \
${ARCHOPTS} \
${GDRIVEOPTS} \
--disable-gconf \
--disable-gnome-vfs \
- --disable-gstreamer-1-0 \
--disable-kde \
--disable-lockdown \
--enable-dbus \
@@ -973,7 +976,6 @@ esac
--enable-ext-nlpsolver \
--enable-ext-wiki-publisher \
--enable-gltf \
- --enable-gstreamer-0-10 \
--enable-hardlink-deliver \
--enable-odk \
--enable-python=internal \
@@ -1018,7 +1020,9 @@ esac
--build=$TARGET \
2>&1 | tee $OUTPUT/configure-${PRGNAM}.log
-touch src.downloaded
+if [ "$USE_GIT" = "no" ]; then
+ touch src.downloaded
+fi
# Compile everything (takes many hours):
touch $OUTPUT/make-${PRGNAM}.log