summaryrefslogtreecommitdiffstats
path: root/source/x/marisa/marisa.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/x/marisa/marisa.SlackBuild')
-rwxr-xr-xsource/x/marisa/marisa.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/source/x/marisa/marisa.SlackBuild b/source/x/marisa/marisa.SlackBuild
index c44ca9922..d220b914e 100755
--- a/source/x/marisa/marisa.SlackBuild
+++ b/source/x/marisa/marisa.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=marisa
SRCNAM=marisa-trie
VERSION=${VERSION:-$(echo $SRCNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d- | rev)}
-BUILD=${BUILD:-7}
+BUILD=${BUILD:-8}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
@@ -92,6 +92,7 @@ if [ ! -r configure ]; then
fi
fi
+PYTHON=python3 \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -105,6 +106,9 @@ CXXFLAGS="$SLKCFLAGS" \
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
+# Regenerate bindings:
+make -C bindings -j1 swig-perl swig-python
+
cd bindings/perl
perl Makefile.PL \
INC="-I$PKG/usr/include" \
@@ -118,10 +122,10 @@ cd bindings/perl
cd -
cd bindings/python
- python setup.py build_ext \
+ python3 setup.py build_ext \
--include-dirs="$PKG/usr/include" \
--library-dirs="$PKG/usr/lib${LIBDIRSUFFIX}" || exit 1
- python setup.py install \
+ python3 setup.py install \
--root=$PKG || exit 1
cd -