summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Christoph Willing <chris.willing@linux.com>2023-07-24 16:05:26 +1000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-29 08:13:39 +0700
commit3bbf69ea1c9eb943365bf5349a8ea0b926e27bfa (patch)
treeab6036b6726328cb307f7ae249ff5bcc393f4616
parent07b90e70e54829e445a96bd7ed38c05d0aa09dde (diff)
downloadslackbuilds-3bbf69ea1c9eb943365bf5349a8ea0b926e27bfa.tar.gz
slackbuilds-3bbf69ea1c9eb943365bf5349a8ea0b926e27bfa.tar.xz
multimedia/mpv: Updated for version 0.36.0
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--multimedia/mpv/README7
-rw-r--r--multimedia/mpv/mpv.SlackBuild45
-rw-r--r--multimedia/mpv/mpv.info8
-rw-r--r--multimedia/mpv/use_older_meson.diff35
4 files changed, 70 insertions, 25 deletions
diff --git a/multimedia/mpv/README b/multimedia/mpv/README
index 53a1ef7469..56ded2b4c9 100644
--- a/multimedia/mpv/README
+++ b/multimedia/mpv/README
@@ -26,9 +26,14 @@ For example, to enable support for OpenAL and SDL2 (both disabled
by default) as well as to disable javascript support (normally
autodetected), you could run:
-BUILD_OPTS="--enable-openal --enable-sdl2 --disable-javascript" \
+BUILD_OPTS="-Dopenal=enabled -Dsdl2=enabled -Djavascript=disabled" \
sh mpv.SlackBuild
Runtime support for youtube videos requires installation of youtube-dl
(available from SBo) to be installed. Watch with something like:
mpv https://www.youtube.com/watch?v=mAFMJ1LnQu8
+
+To enable building with meson/ninja (recommended since waf build is
+to be deprecated), a patch is required to enable use of Slackware 15's
+older version of meson. Unfortunately this disables the ability to
+process configuration/building on Raspberry Pi.
diff --git a/multimedia/mpv/mpv.SlackBuild b/multimedia/mpv/mpv.SlackBuild
index 303ca75b62..02336bc654 100644
--- a/multimedia/mpv/mpv.SlackBuild
+++ b/multimedia/mpv/mpv.SlackBuild
@@ -27,8 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mpv
-VERSION=${VERSION:-0.35.1}
-WAF_VERSION=${WAF_VERSION:-2.0.24}
+VERSION=${VERSION:-0.36.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -72,9 +71,13 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-cp $CWD/waf-$WAF_VERSION ./waf
-sed -i -e 's/python$/python3/' waf
-chmod +x waf
+
+# Needed for 15.0's older meson but disables RPI
+if [ "$(meson --version)" = "0.59.4" ]; then
+ echo "Using meson-0.59.4 for 15.0"
+ patch -p0 < $CWD/use_older_meson.diff
+fi
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -85,29 +88,31 @@ find -L . \
DOCS="Copyright LICENSE.GPL LICENSE.LGPL README.md RELEASE_NOTES VERSION"
MANUAL="DOCS/*.md DOCS/*.rst DOCS/*.txt"
-pipewire="--disable-pipewire" ; [ "${USE_PIPEWIRE:-no}" != "no" ] && pipewire=""
+pipewire="-Dpipewire=disabled" ; [ "${USE_PIPEWIRE:-no}" != "no" ] && pipewire="-Dpipewire=auto"
# This leaves an opening for additional build options.
+# See `meson configure` to see what's available.
BUILD_OPTS=${BUILD_OPTS:-""}
-# Setting CFLAGS and CXXFLAGS breaks configure.
-./waf configure \
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+meson \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
- --confdir=/etc/$PRGNAM \
+ --sysconfdir=/etc \
--mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-libmpv-shared \
- --enable-html-build \
- --enable-dvdnav \
- --enable-cdda \
- --enable-dvbin \
+ -Dbuildtype=release \
+ -Dmanpage-build=enabled \
+ -Dlibmpv=true \
+ -Dhtml-build=enabled \
+ -Dcdda=enabled \
+ -Ddvdnav=enabled \
+ -Ddvbin=enabled \
$pipewire \
- $BUILD_OPTS
-
-./waf build
-./waf --destdir=$PKG install
+ $BUILD_OPTS \
+ . build
+DESTDIR=$PKG ${NINJA:=ninja} -C build -v install
for f in $PKG/etc/mpv/*.conf ; do
mv $f{,.new}
@@ -130,6 +135,8 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/manual
for f in $MANUAL; do
cp -a $f $PKG/usr/doc/$PRGNAM-$VERSION/manual/
done
+cp -a $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share/doc
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/multimedia/mpv/mpv.info b/multimedia/mpv/mpv.info
index 04e3ae8727..d816130812 100644
--- a/multimedia/mpv/mpv.info
+++ b/multimedia/mpv/mpv.info
@@ -1,10 +1,8 @@
PRGNAM="mpv"
-VERSION="0.35.1"
+VERSION="0.36.0"
HOMEPAGE="https://mpv.io/"
-DOWNLOAD="https://github.com/mpv-player/mpv/archive/v0.35.1/mpv-0.35.1.tar.gz \
- https://waf.io/waf-2.0.24"
-MD5SUM="68460d9eb1b42bc6dc13713d4303049b \
- 698f382cca34a08323670f34830325c4"
+DOWNLOAD="https://github.com/mpv-player/mpv/archive/v0.36.0/mpv-0.36.0.tar.gz"
+MD5SUM="68460d9eb1b42bc6dc13713d4303049b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libass libplacebo lua mujs"
diff --git a/multimedia/mpv/use_older_meson.diff b/multimedia/mpv/use_older_meson.diff
new file mode 100644
index 0000000000..856b72ee55
--- /dev/null
+++ b/multimedia/mpv/use_older_meson.diff
@@ -0,0 +1,35 @@
+--- meson.build.orig 2023-07-24 03:10:36.000000000 +1000
++++ meson.build 2023-07-24 11:13:30.945000000 +1000
+@@ -2,7 +2,7 @@
+ 'c',
+ license: ['GPL2+', 'LGPL2.1+'],
+ version: files('./VERSION'),
+- meson_version: '>=0.62.0',
++ meson_version: '>=0.59.4',
+ default_options: [
+ 'buildtype=debugoptimized',
+ 'b_lundef=false',
+@@ -1222,8 +1222,9 @@
+ features += {'gl': true}
+ endif
+
+-rpi = dependency('/opt/vc/lib/pkgconfig/brcmegl.pc', 'brcmegl', required: get_option('rpi'))
+-features += {'rpi': gl_allowed and rpi.found()}
++#rpi = dependency('/opt/vc/lib/pkgconfig/brcmegl.pc', 'brcmegl', required: get_option('rpi'))
++#features += {'rpi': gl_allowed and rpi.found()}
++features += {'rpi': false}
+ if features['rpi']
+ dependencies += rpi
+ features += {'gl': true}
+@@ -1386,8 +1387,9 @@
+ features['rpi'],
+ error_message: 'rpi was not found!',
+ )
+-rpi_mmal = dependency('/opt/vc/lib/pkgconfig/mmal.pc', 'mmal', required: rpi_mmal_opt)
+-features += {'rpi-mmal': rpi_mmal.found()}
++#rpi_mmal = dependency('/opt/vc/lib/pkgconfig/mmal.pc', 'mmal', required: rpi_mmal_opt)
++#features += {'rpi-mmal': rpi_mmal.found()}
++features += {'rpi-mmal': false}
+ if features['rpi-mmal']
+ dependencies += rpi_mmal
+ sources += files('video/out/opengl/hwdec_rpi.c',