summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-06-26 23:40:29 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-08 16:41:56 +0700
commit50d1b63bd395ba251e7c49d6f8fb27b293d4a804 (patch)
tree6bc9041a237ff5786d54a64cb2c05fa2bd8cd94c
parentac2678d65cb769a189ff92d02678e1502d34f1e3 (diff)
downloadslackbuilds-50d1b63bd395ba251e7c49d6f8fb27b293d4a804.tar.gz
slackbuilds-50d1b63bd395ba251e7c49d6f8fb27b293d4a804.tar.xz
python/pyresample: Fix broken symlink in doc dir.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pyresample/pyresample.SlackBuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/python/pyresample/pyresample.SlackBuild b/python/pyresample/pyresample.SlackBuild
index cf0e7bc7ea..b2e6448473 100644
--- a/python/pyresample/pyresample.SlackBuild
+++ b/python/pyresample/pyresample.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230626 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - don't install README in doc dir (it's a broken symlink).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyresample
VERSION=${VERSION:-1.5.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -73,19 +73,16 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+ || true
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.txt PKG-INFO README docs/source/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt PKG-INFO docs/source/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install