summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Juan M. Lasca <juanmlasca@gmail.com>2023-10-26 21:54:26 +0900
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-28 13:11:51 +0700
commit53e41de2a9ad3622c010ccbc7a3baadfa0c662ce (patch)
tree27aeeea640ed62b4b499e02c9b24170d1f52826e
parent3c5fc8ac548c4de69b813a3cfe9fa695d0af3711 (diff)
downloadslackbuilds-53e41de2a9ad3622c010ccbc7a3baadfa0c662ce.tar.gz
slackbuilds-53e41de2a9ad3622c010ccbc7a3baadfa0c662ce.tar.xz
libraries/libgedit-gtksourceview: Added (GTK+ text editing widget).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/libgedit-gtksourceview/README6
-rw-r--r--libraries/libgedit-gtksourceview/libgedit-gtksourceview.SlackBuild117
-rw-r--r--libraries/libgedit-gtksourceview/libgedit-gtksourceview.info10
-rw-r--r--libraries/libgedit-gtksourceview/slack-desc19
4 files changed, 152 insertions, 0 deletions
diff --git a/libraries/libgedit-gtksourceview/README b/libraries/libgedit-gtksourceview/README
new file mode 100644
index 0000000000..471e04dbda
--- /dev/null
+++ b/libraries/libgedit-gtksourceview/README
@@ -0,0 +1,6 @@
+libgedit-gtksourceview is a library that extends GtkTextView,
+the standard GTK widget for multiline text editing. This
+library adds support for syntax highlighting, undo/redo, file
+loading and saving, search and replace, a completion system,
+printing, displaying line numbers, and other features typical
+of a source code editor.
diff --git a/libraries/libgedit-gtksourceview/libgedit-gtksourceview.SlackBuild b/libraries/libgedit-gtksourceview/libgedit-gtksourceview.SlackBuild
new file mode 100644
index 0000000000..67327742e3
--- /dev/null
+++ b/libraries/libgedit-gtksourceview/libgedit-gtksourceview.SlackBuild
@@ -0,0 +1,117 @@
+#!/bin/bash
+
+# Slackware build script for libgedit-gtksourceview
+
+# Copyright 2010,2011 Robby Workman, Northport, Alabama, USA
+# Copyright 2011 byteframe
+# Maintained 2020, 2021, 2022 by Donald Cooley <chytraeu@sdf.org>
+# Copyright 2022 Juan M. Lasca <juanmlasca@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Special thanks to Brandon Pribula, who kindly handed over maintenance to me.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=libgedit-gtksourceview
+VERSION=${VERSION:-299.0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# circunvent meson version mismtach (fs.copyfile not available)
+# avoid gtk_doc, which uses fs.copyfile
+# replace unnecesary version bump of gio-2.0
+sed -i "s/meson_version: '>= 0.64'/meson_version: '>= 0.59'/;
+ s/'gio-2.0', version: '>= 2.74'/'gio-2.0', version: '>= 2.70'/" meson.build
+
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dgtk_doc=false \
+ -Dstrip=true
+"${NINJA:=ninja}"
+DESTDIR=$PKG $NINJA install
+cd ..
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README NEWS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/libgedit-gtksourceview/libgedit-gtksourceview.info b/libraries/libgedit-gtksourceview/libgedit-gtksourceview.info
new file mode 100644
index 0000000000..51807607ed
--- /dev/null
+++ b/libraries/libgedit-gtksourceview/libgedit-gtksourceview.info
@@ -0,0 +1,10 @@
+PRGNAM="libgedit-gtksourceview"
+VERSION="299.0.4"
+HOMEPAGE="https://gedit-technology.net/"
+DOWNLOAD="https://gedit-technology.net/tarballs/libgedit-gtksourceview/libgedit-gtksourceview-299.0.4.tar.xz"
+MD5SUM="3f96094715a897567e3df7f72ec6c9f0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Juan M. Lasca"
+EMAIL="juanmlasca@gmail.com"
diff --git a/libraries/libgedit-gtksourceview/slack-desc b/libraries/libgedit-gtksourceview/slack-desc
new file mode 100644
index 0000000000..6656890884
--- /dev/null
+++ b/libraries/libgedit-gtksourceview/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libgedit-gtksourceview: libgedit-gtksourceview (GTK+ text editing widget)
+libgedit-gtksourceview:
+libgedit-gtksourceview: libgedit-gtksourceview is a library that extends GtkTextView,
+libgedit-gtksourceview: the standard GTK widget for multiline text editing. This
+libgedit-gtksourceview: library adds support for syntax highlighting, undo/redo, file
+libgedit-gtksourceview: loading and saving, search and replace, a completion system,
+libgedit-gtksourceview: printing, displaying line numbers, and other features typical
+libgedit-gtksourceview: of a source code editor.
+libgedit-gtksourceview:
+libgedit-gtksourceview: for more information, see: https://gedit-technology.net/
+libgedit-gtksourceview: