summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2023-02-24 20:13:46 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-03-04 08:06:36 +0700
commit615f4af75a4f361425f74163d3f7d8ea51b56594 (patch)
treeb639829c3741772ace25dc3de33d51590cf1fd37
parent4e538cfab8d64ee58f9084045dffe28e1aadc841 (diff)
downloadslackbuilds-615f4af75a4f361425f74163d3f7d8ea51b56594.tar.gz
slackbuilds-615f4af75a4f361425f74163d3f7d8ea51b56594.tar.xz
development/spyder: Updated for version 5.3.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/spyder/README5
-rw-r--r--development/spyder/slack-desc2
-rw-r--r--development/spyder/spyder.SlackBuild23
-rw-r--r--development/spyder/spyder.info8
4 files changed, 23 insertions, 15 deletions
diff --git a/development/spyder/README b/development/spyder/README
index 65c9fe92a3..fa538cac4c 100644
--- a/development/spyder/README
+++ b/development/spyder/README
@@ -2,5 +2,6 @@ Spyder (previously known as Pydee) is a powerful interactive
development environment for the Python language with advanced editing,
interactive testing, debugging and introspection features.
-Optional dependencies: ipython, rope, matplotlib, numpy, pyflakes,
-pep8, pylint, Sphinx and scipy
+spyder 5.3.1 is the last available version in Slackware 15.0. Newer
+versions require a newer python3-lsp-server, which in turn requires
+a newer python-setuptools.
diff --git a/development/spyder/slack-desc b/development/spyder/slack-desc
index add5ec82a4..25d19c5981 100644
--- a/development/spyder/slack-desc
+++ b/development/spyder/slack-desc
@@ -12,7 +12,7 @@ spyder: Spyder (previously known as Pydee) is a powerful interactive
spyder: development environment for the Python language with advanced editing,
spyder: interactive testing, debugging and introspection features.
spyder:
-spyder: Homepage: http://code.google.com/p/spyderlib/
+spyder: Homepage: https://github.com/spyder-ide/spyder
spyder:
spyder:
spyder:
diff --git a/development/spyder/spyder.SlackBuild b/development/spyder/spyder.SlackBuild
index 55f8e28387..15a7b5dd66 100644
--- a/development/spyder/spyder.SlackBuild
+++ b/development/spyder/spyder.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=spyder
-VERSION=${VERSION:-2.3.9}
+VERSION=${VERSION:-5.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -88,23 +85,33 @@ for FILE in $(find . -type f \( ! -iname "*\.*o" ! -iname "*\.png" \) \
mv ${FILE}.new $FILE
done
-python setup.py install --root=$PKG
+# Allow SlackBuilds python libraries versions
+sed 's|IPYTHON_REQVER = ">=7.31.1;<8.0.0"|IPYTHON_REQVER = ">=7.31.1"|' -i spyder/dependencies.py
+sed "s|QDARKSTYLE_REQVER = '>=3.0.2;<3.1.0'|QDARKSTYLE_REQVER = '>=3.0.2'|" -i spyder/dependencies.py
+sed "s|QTCONSOLE_REQVER = '>=5.3.0;<5.4.0'|QTCONSOLE_REQVER = '>=5.3.0'|" -i spyder/dependencies.py
+sed "s|SPYDER_KERNELS_REQVER = '>=2.3.1;<2.4.0'|SPYDER_KERNELS_REQVER = '>=2.3.1'|" -i spyder/dependencies.py
+sed "s|ipython>=7.31.1,<8.0.0|ipython>=7.31.1|" -i setup.py
+sed "s|qdarkstyle>=3.0.2,<3.1.0|qdarkstyle>=3.0.2|" -i setup.py
+sed "s|qtconsole>=5.3.0,<5.4.0|qtconsole>=5.3.0|" -i setup.py
+sed "s|spyder-kernels>=2.3.1,<2.4.0|spyder-kernels>=2.3.1|" -i setup.py
+
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
for i in 16 24 32 36 48 64 96 128; do
- convert spyderlib/images/$PRGNAM.svg -resize ${i}x${i}! $PRGNAM-$i.png
+ convert spyder/images/$PRGNAM.svg -resize ${i}x${i}! $PRGNAM-$i.png
install -D -m 0644 $PRGNAM-$i.png $PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM.png
done
-install -D -m 0644 spyderlib/images/$PRGNAM.svg \
+install -D -m 0644 spyder/images/$PRGNAM.svg \
$PKG/usr/share/icons/hicolor/scalable/apps/$PRGNAM.svg
# Remove unwanted files/directories.
rm -rf $PKG/usr/share/pixmaps $PKG/usr/bin/spyder_win_post_install.py
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS *.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.txt LICENSE.txt NOTICE.txt *.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/spyder/spyder.info b/development/spyder/spyder.info
index ef76a019e8..9d7233299a 100644
--- a/development/spyder/spyder.info
+++ b/development/spyder/spyder.info
@@ -1,10 +1,10 @@
PRGNAM="spyder"
-VERSION="2.3.9"
+VERSION="5.3.1"
HOMEPAGE="https://github.com/spyder-ide/spyder"
-DOWNLOAD="https://github.com/spyder-ide/spyder/archive/v2.3.9/spyder-2.3.9.tar.gz"
-MD5SUM="b8cf463c6eeaed01355ebac0d72f2c41"
+DOWNLOAD="https://github.com/spyder-ide/spyder/archive/v5.3.1/spyder-5.3.1.tar.gz"
+MD5SUM="dd5827e70667ef344aa7b6b8a4566054"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="atomicwrites autopep8 flake8 jellyfish jupyter-nbconvert numpydoc python-keyring python3-PyQtWebEngine python3-cookiecutter python3-pyflakes python3-intervaltree python3-lsp-black python3-pylint-venv python3-pyls-spyder python3-qstylizer python3-qtawesome python3-rope python3-rtree python3-spyder-kernels python3-three-merge python3-watchdog yapf"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"