summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2023-02-21 00:10:16 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-02-25 09:18:02 +0700
commit635429ec7a086f38db8da24975099c306e172900 (patch)
treee10761323da9171feacb9dc696c0c9b1305c566f
parentf2ea2833163cb23163a1c41284dad34cc03e813c (diff)
downloadslackbuilds-635429ec7a086f38db8da24975099c306e172900.tar.gz
slackbuilds-635429ec7a086f38db8da24975099c306e172900.tar.xz
development/python3-spyder-kernels: Added (Jupyter kernels)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/python3-spyder-kernels/README6
-rw-r--r--development/python3-spyder-kernels/python3-spyder-kernels.SlackBuild99
-rw-r--r--development/python3-spyder-kernels/python3-spyder-kernels.info10
-rw-r--r--development/python3-spyder-kernels/slack-desc19
4 files changed, 134 insertions, 0 deletions
diff --git a/development/python3-spyder-kernels/README b/development/python3-spyder-kernels/README
new file mode 100644
index 0000000000..5ca498cf43
--- /dev/null
+++ b/development/python3-spyder-kernels/README
@@ -0,0 +1,6 @@
+Package that provides Jupyter kernels for use with the consoles of
+Spyder, the Scientific Python Development Environment.
+
+These kernels can launched either through Spyder itself or in an
+independent Python session, and allow for interactive or file-based
+execution of Python code inside Spyder.
diff --git a/development/python3-spyder-kernels/python3-spyder-kernels.SlackBuild b/development/python3-spyder-kernels/python3-spyder-kernels.SlackBuild
new file mode 100644
index 0000000000..1e229ebe18
--- /dev/null
+++ b/development/python3-spyder-kernels/python3-spyder-kernels.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/bash
+
+# Slackware build script for python3-spyder-kernels
+
+# Copyright 2023 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-spyder-kernels
+VERSION=${VERSION:-2.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=spyder-kernels
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Remove version limitations for ipykernel, ipython and jupyter_client
+sed -i 's|ipykernel>=6.16.1,<7|ipykernel>=6.16.1|' setup.py
+sed -i 's|ipython>=7.31.1,<9|ipython>=7.31.1|' setup.py
+sed -i 's|jupyter-client>=7.4.9,<8|jupyter-client>=7.4.9|' setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.txt CHANGELOG.md LICENSE.txt README.md RELEASE.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/python3-spyder-kernels/python3-spyder-kernels.info b/development/python3-spyder-kernels/python3-spyder-kernels.info
new file mode 100644
index 0000000000..eec4f37498
--- /dev/null
+++ b/development/python3-spyder-kernels/python3-spyder-kernels.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-spyder-kernels"
+VERSION="2.4.2"
+HOMEPAGE="https://github.com/spyder-ide/spyder-kernels"
+DOWNLOAD="https://github.com/spyder-ide/spyder-kernels/archive/v2.4.2/spyder-kernels-2.4.2.tar.gz"
+MD5SUM="60f83d3914cc0f5f90122176a0b802e8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jupyter-ipykernel cloudpickle python3-wurlitzer"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/development/python3-spyder-kernels/slack-desc b/development/python3-spyder-kernels/slack-desc
new file mode 100644
index 0000000000..6ae50a200b
--- /dev/null
+++ b/development/python3-spyder-kernels/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-spyder-kernels: python3-spyder-kernels (Jupyter kernels for the Spyder console)
+python3-spyder-kernels:
+python3-spyder-kernels: Package that provides Jupyter kernels for use with the consoles of
+python3-spyder-kernels: Spyder, the Scientific Python Development Environment.
+python3-spyder-kernels:
+python3-spyder-kernels: These kernels can launched either through Spyder itself or in an
+python3-spyder-kernels: independent Python session, and allow for interactive or file-based
+python3-spyder-kernels: execution of Python code inside Spyder.
+python3-spyder-kernels:
+python3-spyder-kernels:
+python3-spyder-kernels: