summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-15 22:31:27 +0700
committer Robby Workman <rworkman@slackbuilds.org>2021-04-21 19:54:28 -0500
commit772481c9d846eb5259ac634e50824c4d28c64b42 (patch)
tree4e241b5223c15ab1a665b5f1abdeaf1c74c21f61
parenta3d7afde5ddc11e4fd5b3138227125c6716703d3 (diff)
downloadslackbuilds-772481c9d846eb5259ac634e50824c4d28c64b42.tar.gz
slackbuilds-772481c9d846eb5259ac634e50824c4d28c64b42.tar.xz
python/py4j: Removed (No maintainer).
-rw-r--r--python/py4j/README5
-rw-r--r--python/py4j/py4j.SlackBuild85
-rw-r--r--python/py4j/py4j.info10
-rw-r--r--python/py4j/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/python/py4j/README b/python/py4j/README
deleted file mode 100644
index 130432d15b..0000000000
--- a/python/py4j/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Py4J enables Python programs running in a Python interpreter to dynamically
-access Java objects in a Java Virtual Machine. Methods are called as if the
-Java objects resided in the Python interpreter and Java collections can be
-accessed through standard Python collection methods. Py4J also enables Java
-programs to call back Python objects.
diff --git a/python/py4j/py4j.SlackBuild b/python/py4j/py4j.SlackBuild
deleted file mode 100644
index d3681e81b9..0000000000
--- a/python/py4j/py4j.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for py4j
-
-# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=py4j
-VERSION=${VERSION:-0.8.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/py4j/py4j.info b/python/py4j/py4j.info
deleted file mode 100644
index 6755bff962..0000000000
--- a/python/py4j/py4j.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="py4j"
-VERSION="0.8.2"
-HOMEPAGE="http://py4j.sourceforge.net"
-DOWNLOAD="https://pypi.python.org/packages/source/p/py4j/py4j-0.8.2.tar.gz"
-MD5SUM="5d06e9e30314be9dc1c87d682b4eddf7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="orphaned - no maintainer"
-EMAIL="nobody@nowhere"
diff --git a/python/py4j/slack-desc b/python/py4j/slack-desc
deleted file mode 100644
index 1b3521ae74..0000000000
--- a/python/py4j/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-py4j: py4j (bridge between Python and Java)
-py4j:
-py4j: Py4J enables Python programs running in a Python interpreter to
-py4j: dynamically access Java objects in a Java Virtual Machine. Methods are
-py4j: called as if the Java objects resided in the Python interpreter and
-py4j: Java collections can be accessed through standard Python collection
-py4j: methods. Py4J also enables Java programs to call back Python objects.
-py4j:
-py4j:
-py4j:
-py4j: