summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-25 23:59:23 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-29 06:58:15 +0700
commit7ef847105a6fd6ee1e8aa2a5b4748e7638cc0c82 (patch)
tree02ff4e6a763f027a217e3abc44b333f647c89c24
parent3e6d120b2aea0cf157335bb941e47aca592c6cb1 (diff)
downloadslackbuilds-7ef847105a6fd6ee1e8aa2a5b4748e7638cc0c82.tar.gz
slackbuilds-7ef847105a6fd6ee1e8aa2a5b4748e7638cc0c82.tar.xz
libraries/BeautifulSoup4: Add python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild19
1 files changed, 18 insertions, 1 deletions
diff --git a/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild b/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild
index 709abf4da9..2b26ef8a52 100644
--- a/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild
+++ b/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=BeautifulSoup4
SRCNAM=${PRGNAM,,}
VERSION=${VERSION:-4.5.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,6 +72,23 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ cd $TMP
+ rm -rf $SRCNAM-$VERSION
+ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+ cd $SRCNAM-$VERSION
+ chown -R root:root .
+ find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ sed -i "s/-rfI/-rf/" convert-py3k
+ sh convert-py3k
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true