summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-02-12 11:47:09 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-13 09:17:49 +0700
commit91194e609aeafc88e742c2fe5f6d74238377b612 (patch)
treec5bc47e17ddcdf45f2fbf75355576c9ff3c6e3b4
parentbfde56e24a39b4979d9a36a3cf9c2d8b8f3651ae (diff)
downloadslackbuilds-91194e609aeafc88e742c2fe5f6d74238377b612.tar.gz
slackbuilds-91194e609aeafc88e742c2fe5f6d74238377b612.tar.xz
system/shake: Updated for version 1.0.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/shake/README2
-rw-r--r--system/shake/shake-dev_t-include.patch10
-rw-r--r--system/shake/shake.SlackBuild79
-rw-r--r--system/shake/shake.info8
-rw-r--r--system/shake/slack-desc2
5 files changed, 43 insertions, 58 deletions
diff --git a/system/shake/README b/system/shake/README
index 0750c439ff..989999ae4c 100644
--- a/system/shake/README
+++ b/system/shake/README
@@ -1,4 +1,4 @@
-Shake is a filesystem defragmenter that runs in userspace.
+shake: shake (filesystem defragmenter that runs in userspace)
Contrary to xfs_fsr, it uses functions common to all filesystems and
can be used to selectively defragment files.
diff --git a/system/shake/shake-dev_t-include.patch b/system/shake/shake-dev_t-include.patch
deleted file mode 100644
index 19ca1c2ae9..0000000000
--- a/system/shake/shake-dev_t-include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- judge.h_old 2013-11-15 22:00:35.085301859 +0100
-+++ judge.h 2013-11-15 22:00:54.811967958 +0100
-@@ -22,6 +22,7 @@
- #include <stdbool.h>
- #include <fcntl.h>
- #include <time.h>
-+#include <sys/stat.h>
- typedef unsigned int uint;
- typedef long long int llint;
-
diff --git a/system/shake/shake.SlackBuild b/system/shake/shake.SlackBuild
index 7e18b67bc9..8d8b9be807 100644
--- a/system/shake/shake.SlackBuild
+++ b/system/shake/shake.SlackBuild
@@ -22,25 +22,25 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220212 bkw: Modified by SlackBuilds.org:
+# - updated for v1.0.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=shake
-VERSION=${VERSION:-0.999}
+VERSION=${VERSION:-1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,8 +50,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -69,46 +69,41 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-fs-$VERSION
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-fs-$VERSION
+cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# patch for "error: unknown type name 'dev_t'"
-patch -p0 < $CWD/shake-dev_t-include.patch
-
+find . -type f -exec chmod 644 {} \+
+find . -type d -exec chmod 755 {} \+
+
+# 20220212 bkw: put man pages in the right place, and since these are
+# sysadmin tools (section 8 manpages), put the binaries in /usr/sbin.
+sed -i -e '/DESTINATION/s,share/man,man,' \
+ -e '/DESTINATION/s,bin,sbin,' \
+ CMakeLists.txt
+
+# 20220212 bkw: sorry, this bugs me.
+sed -i 's,choosen,chosen,g' doc/unattr-man_insert unattr.c
+sed -i -e 's,there is no,there are no,g' \
+ -e 's,shake read from,shake reads from,g' \
+ doc/shake-man_insert \
+ msg.c
+
+mkdir -p build
cd build
-CFLAGS="$SLKCFLAGS" \
-cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- ..
-
-make VERBOSE=1
-make install DESTDIR=$PKG
-cd -
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-#Move manpages manually
-mkdir $PKG/usr/man
-mv $PKG/usr/share/man/* $PKG/usr/man/
-rm -R $PKG/usr/share
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+ cmake \
+ -DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS -DNDEBUG" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make VERBOSE=1
+ make install/strip DESTDIR=$PKG
+cd ..
+gzip -9 $PKG/usr/man/man*/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- GPL.txt INSTALL NEWS \
- $PKG/usr/doc/$PRGNAM-$VERSION
-chmod -R 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
+cp -a README.md doc/FDL.txt GPL.txt NEWS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/shake/shake.info b/system/shake/shake.info
index 31bbf27b23..9651d259be 100644
--- a/system/shake/shake.info
+++ b/system/shake/shake.info
@@ -1,8 +1,8 @@
PRGNAM="shake"
-VERSION="0.999"
-HOMEPAGE="https://savannah.nongnu.org/projects/shake"
-DOWNLOAD="http://mirror.lihnidos.org/GNU/savannah/shake/shake-0.999.tar.gz"
-MD5SUM="20b5086ec8920ad91528dec81a576c1d"
+VERSION="1.0"
+HOMEPAGE="http://vleu.net/shake/"
+DOWNLOAD="https://github.com/unbrice/shake/archive/v1.0/shake-1.0.tar.gz"
+MD5SUM="e5759e180b765a6ff13e77d775652e92"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/shake/slack-desc b/system/shake/slack-desc
index 4a92f4b719..e546b7dea0 100644
--- a/system/shake/slack-desc
+++ b/system/shake/slack-desc
@@ -12,7 +12,7 @@ shake: Contrary to xfs_fsr, it uses functions common to all filesystems and
shake: can be used to selectively defragment files.
shake: For best results, mount your partitions with the user_xattr option.
shake:
-shake: Homepage: https://savannah.nongnu.org/projects/shake
+shake:
shake:
shake:
shake: