summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author dsomero <xgizzmo@slackbuilds.org>2011-07-13 22:23:54 -0400
committer Niels Horn <niels.horn@slackbuilds.org>2011-07-14 21:54:06 -0300
commitf03182fce9ab2f6a266e9c2bb221279aa381648c (patch)
tree80f579f44b44750ec3ec2d954ffc633f4c7c7f5e
parentb6f0e2e1d7892a4bb95935b46b7b2e6c8ef7b9c1 (diff)
downloadslackbuilds-f03182fce9ab2f6a266e9c2bb221279aa381648c.tar.gz
slackbuilds-f03182fce9ab2f6a266e9c2bb221279aa381648c.tar.xz
system/python-ranger: Removed (renamed to system/ranger)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--system/python-ranger/README6
-rw-r--r--system/python-ranger/python-ranger.SlackBuild93
-rw-r--r--system/python-ranger/python-ranger.info10
-rw-r--r--system/python-ranger/slack-desc19
4 files changed, 0 insertions, 128 deletions
diff --git a/system/python-ranger/README b/system/python-ranger/README
deleted file mode 100644
index 110c4c6f7c..0000000000
--- a/system/python-ranger/README
+++ /dev/null
@@ -1,6 +0,0 @@
-A multi-column display allows viewing in a tree-like manner. You can
-preview the content of the selected file or directory, copy or move
-files around with the VIM-like commands dd and yy, execute predefined
-applications when opening a file, etc...
-Everything is fully customizable and written in Python (2.6 and 3.1
-compatible) using curses for the text-based user interface.
diff --git a/system/python-ranger/python-ranger.SlackBuild b/system/python-ranger/python-ranger.SlackBuild
deleted file mode 100644
index 98af7e82fe..0000000000
--- a/system/python-ranger/python-ranger.SlackBuild
+++ /dev/null
@@ -1,93 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-ranger
-# Copyright 2010-2011 David Woodfall <dave@dawoodfall.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-ranger
-VERSION=${VERSION:-1.4.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=$(echo $PRGNAM | cut -d- -f2)
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
-CHANGELOG COPYING INSTALL README doc/HACKING doc/TODO \
-doc/colorschemes.txt doc/print_colors.py doc/print_keys.py \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/python-ranger/python-ranger.info b/system/python-ranger/python-ranger.info
deleted file mode 100644
index 4fe934d665..0000000000
--- a/system/python-ranger/python-ranger.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-ranger"
-VERSION="1.4.1"
-HOMEPAGE="https://savannah.nongnu.org/projects/ranger/"
-DOWNLOAD="http://nongnu.uib.no/ranger/releases/ranger-1.4.1.tar.gz"
-MD5SUM="b59eefde55fdf65b2a7599f9d8ac0632"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="David Woodfall"
-EMAIL="dave@dawoodfall.net"
-APPROVED="Niels Horn"
diff --git a/system/python-ranger/slack-desc b/system/python-ranger/slack-desc
deleted file mode 100644
index ea1f59e7d9..0000000000
--- a/system/python-ranger/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-python-ranger: Ranger (a curses file manager that uses vi/vim bindings)
-python-ranger:
-python-ranger: A multi-column display allows viewing in a tree-like manner. You can
-python-ranger: preview the content of the selected file or directory, copy or move
-python-ranger: files around with the VIM-like commands dd and yy, execute predefined
-python-ranger: applications when opening a file, etc...
-python-ranger: Everything is fully customizable and written in Python (2.6 and 3.1
-python-ranger: compatible) using curses for the text-based user interface.
-python-ranger:
-python-ranger: Homepage: https://savannah.nongnu.org/projects/ranger/
-python-ranger: