summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-06 17:09:25 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:44 +0700
commitfd743313af52c72de96b367b50e3d2ec9808cfd1 (patch)
tree45f7a276830eec0a9edebe286d02cc28c1505051
parente8082337623f36255954d959db07c90907ca490a (diff)
downloadslackbuilds-fd743313af52c72de96b367b50e3d2ec9808cfd1.tar.gz
slackbuilds-fd743313af52c72de96b367b50e3d2ec9808cfd1.tar.xz
python/python-oauth: Renamed python2-oauth.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python2-oauth/README (renamed from python/python-oauth/README)0
-rw-r--r--python/python2-oauth/python2-oauth.SlackBuild (renamed from python/python-oauth/python-oauth.SlackBuild)10
-rw-r--r--python/python2-oauth/python2-oauth.info (renamed from python/python-oauth/python-oauth.info)2
-rw-r--r--python/python2-oauth/slack-desc (renamed from python/python-oauth/slack-desc)24
4 files changed, 18 insertions, 18 deletions
diff --git a/python/python-oauth/README b/python/python2-oauth/README
index 696a32657a..696a32657a 100644
--- a/python/python-oauth/README
+++ b/python/python2-oauth/README
diff --git a/python/python-oauth/python-oauth.SlackBuild b/python/python2-oauth/python2-oauth.SlackBuild
index cf244e86a2..4882c71f13 100644
--- a/python/python-oauth/python-oauth.SlackBuild
+++ b/python/python2-oauth/python2-oauth.SlackBuild
@@ -21,7 +21,7 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-oauth
+PRGNAM=python2-oauth
VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -30,7 +30,7 @@ SRCNAM=oauth
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -70,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-oauth/python-oauth.info b/python/python2-oauth/python2-oauth.info
index 51c36a317f..671bb9b6a7 100644
--- a/python/python-oauth/python-oauth.info
+++ b/python/python2-oauth/python2-oauth.info
@@ -1,4 +1,4 @@
-PRGNAM="python-oauth"
+PRGNAM="python2-oauth"
VERSION="1.0.1"
HOMEPAGE="http://code.google.com/p/oauth/"
DOWNLOAD="https://pypi.python.org/packages/source/o/oauth/oauth-1.0.1.tar.gz"
diff --git a/python/python-oauth/slack-desc b/python/python2-oauth/slack-desc
index c32a141468..da4e6d0f21 100644
--- a/python/python-oauth/slack-desc
+++ b/python/python2-oauth/slack-desc
@@ -5,15 +5,15 @@
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
- |-----handy-ruler------------------------------------------------------|
-python-oauth: python-oauth (open protocol to allow API authentication)
-python-oauth:
-python-oauth: An open protocol to allow API authentication from desktop and
-python-oauth: web applications.
-python-oauth:
-python-oauth:
-python-oauth:
-python-oauth:
-python-oauth:
-python-oauth:
-python-oauth:
+ |-----handy-ruler------------------------------------------------------|
+python2-oauth: python2-oauth (open protocol to allow API authentication)
+python2-oauth:
+python2-oauth: An open protocol to allow API authentication from desktop and
+python2-oauth: web applications.
+python2-oauth:
+python2-oauth:
+python2-oauth:
+python2-oauth:
+python2-oauth:
+python2-oauth:
+python2-oauth: