summaryrefslogtreecommitdiffstats
path: root/development/spyder
diff options
context:
space:
mode:
author isaackwy <isaacyu@protonmail.com>2023-12-30 12:23:26 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-31 18:44:58 +0700
commit145895333bf028f4b16ecf10fe4b010c3f77a4ec (patch)
tree173db0d254bcbcd8657c77b258c580218f76b815 /development/spyder
parent17f9c0035f3db9dc67f617aac63a6b89174e0dd2 (diff)
downloadslackbuilds-145895333bf028f4b16ecf10fe4b010c3f77a4ec.tar.gz
slackbuilds-145895333bf028f4b16ecf10fe4b010c3f77a4ec.tar.xz
development/spyder: Update for 5.4.0 (+new maintainer)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/spyder')
-rw-r--r--development/spyder/README5
-rw-r--r--development/spyder/spyder.SlackBuild17
-rw-r--r--development/spyder/spyder.info12
3 files changed, 19 insertions, 15 deletions
diff --git a/development/spyder/README b/development/spyder/README
index fa538cac4c..4da247a037 100644
--- a/development/spyder/README
+++ b/development/spyder/README
@@ -2,6 +2,5 @@ Spyder (previously known as Pydee) is a powerful interactive
development environment for the Python language with advanced editing,
interactive testing, debugging and introspection features.
-spyder 5.3.1 is the last available version in Slackware 15.0. Newer
-versions require a newer python3-lsp-server, which in turn requires
-a newer python-setuptools.
+spyder 5.4.0 is the last available version in Slackware 15.0. Newer
+versions require a newer python3-lsp-server.
diff --git a/development/spyder/spyder.SlackBuild b/development/spyder/spyder.SlackBuild
index d5e41ee226..f0e583790a 100644
--- a/development/spyder/spyder.SlackBuild
+++ b/development/spyder/spyder.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for spyder
# Copyright 2010-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=spyder
-VERSION=${VERSION:-5.3.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-5.4.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -87,13 +88,17 @@ done
# Allow SlackBuilds python libraries versions
sed 's|IPYTHON_REQVER = ">=7.31.1;<8.0.0"|IPYTHON_REQVER = ">=7.31.1"|' -i spyder/dependencies.py
+sed "s|JEDI_REQVER = '>=0.17.2;<0.19.0'|JEDI_REQVER = '>=0.17.2'|" -i spyder/dependencies.py
+sed "s|PYLINT_REQVER = '>=2.5.0;<3.0'|PYLINT_REQVER = '>=2.5.0'|" -i spyder/dependencies.py
sed "s|QDARKSTYLE_REQVER = '>=3.0.2;<3.1.0'|QDARKSTYLE_REQVER = '>=3.0.2'|" -i spyder/dependencies.py
-sed "s|QTCONSOLE_REQVER = '>=5.3.0;<5.4.0'|QTCONSOLE_REQVER = '>=5.3.0'|" -i spyder/dependencies.py
-sed "s|SPYDER_KERNELS_REQVER = '>=2.3.1;<2.4.0'|SPYDER_KERNELS_REQVER = '>=2.3.1'|" -i spyder/dependencies.py
+sed "s|QTCONSOLE_REQVER = '>=5.4.0;<5.5.0'|QTCONSOLE_REQVER = '>=5.4.0'|" -i spyder/dependencies.py
+sed "s|SPYDER_KERNELS_REQVER = '>=2.4.0;<2.5.0'|SPYDER_KERNELS_REQVER = '>=2.4.0'|" -i spyder/dependencies.py
sed "s|ipython>=7.31.1,<8.0.0|ipython>=7.31.1|" -i setup.py
+sed "s|jedi>=0.17.2,<0.19.0|jedi>=0.17.2|" -i setup.py
+sed "s|pylint>=2.5.0,<3.0|pylint>=2.5.0|" -i setup.py
sed "s|qdarkstyle>=3.0.2,<3.1.0|qdarkstyle>=3.0.2|" -i setup.py
-sed "s|qtconsole>=5.3.0,<5.4.0|qtconsole>=5.3.0|" -i setup.py
-sed "s|spyder-kernels>=2.3.1,<2.4.0|spyder-kernels>=2.3.1|" -i setup.py
+sed "s|qtconsole>=5.4.0,<5.5.0|qtconsole>=5.5.0|" -i setup.py
+sed "s|spyder-kernels>=2.4.0,<2.5.0|spyder-kernels>=2.4.0|" -i setup.py
python3 setup.py install --root=$PKG
diff --git a/development/spyder/spyder.info b/development/spyder/spyder.info
index d7486e9dc3..7c926edd95 100644
--- a/development/spyder/spyder.info
+++ b/development/spyder/spyder.info
@@ -1,10 +1,10 @@
PRGNAM="spyder"
-VERSION="5.3.1"
+VERSION="5.4.0"
HOMEPAGE="https://github.com/spyder-ide/spyder"
-DOWNLOAD="https://github.com/spyder-ide/spyder/archive/v5.3.1/spyder-5.3.1.tar.gz"
-MD5SUM="dd5827e70667ef344aa7b6b8a4566054"
+DOWNLOAD="https://github.com/spyder-ide/spyder/archive/v5.4.0/spyder-5.4.0.tar.gz"
+MD5SUM="5ebc8154007f12dc28581d2fcbd32711"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-atomicwrites autopep8 flake8 jellyfish jupyter-nbconvert numpydoc python3-keyring python3-PyQtWebEngine python3-cookiecutter python3-intervaltree python3-lsp-black python3-pylint-venv python3-pyls-spyder python3-qstylizer python3-qtawesome python3-rope python3-rtree python3-spyder-kernels python3-three-merge python3-watchdog yapf python3-textdistance jupyter-qtconsole QDarkStyle python3-pydocstyle"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
+REQUIRES="python3-atomicwrites autopep8 flake8 jellyfish jupyter-nbconvert numpydoc python3-keyring python3-PyQtWebEngine python3-cookiecutter python3-intervaltree python3-lsp-black python3-pylint-venv python3-pyls-spyder python3-qstylizer python3-qtawesome python3-rope python3-rtree python3-spyder-kernels python3-three-merge python3-watchdog yapf python3-textdistance jupyter-qtconsole QDarkStyle python3-pydocstyle python3-whatthepatch"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"