summaryrefslogtreecommitdiffstats
path: root/libraries/grpc
diff options
context:
space:
mode:
author isaackwy <isaacyu@protonmail.com>2024-01-12 19:57:30 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-14 08:38:25 +0700
commitb3149d7b8b06c72b033424067d2279914822b435 (patch)
tree7b5a5344bc167c353234080449506c02f6b45c30 /libraries/grpc
parentd4a195d3a8f76378a7ba55bf62619756cb48088f (diff)
downloadslackbuilds-b3149d7b8b06c72b033424067d2279914822b435.tar.gz
slackbuilds-b3149d7b8b06c72b033424067d2279914822b435.tar.xz
libraries/grpc: Remove Python 3 support
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/grpc')
-rw-r--r--libraries/grpc/README3
-rw-r--r--libraries/grpc/grpc.SlackBuild9
2 files changed, 3 insertions, 9 deletions
diff --git a/libraries/grpc/README b/libraries/grpc/README
index 4cd80295c7..03152b0b7c 100644
--- a/libraries/grpc/README
+++ b/libraries/grpc/README
@@ -2,3 +2,6 @@ gRPC is a modern, open source, high-performance remote procedure call
(RPC) framework that can run anywhere. gRPC enables client and server
applications to communicate transparently, and simplifies the building
of connected systems.
+
+This SlackBuild builds gRPC in C++. python3-grpcio contains the Python 3
+build of gRPC.
diff --git a/libraries/grpc/grpc.SlackBuild b/libraries/grpc/grpc.SlackBuild
index 17bd561ab5..fc554822ca 100644
--- a/libraries/grpc/grpc.SlackBuild
+++ b/libraries/grpc/grpc.SlackBuild
@@ -103,15 +103,6 @@ CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
make install-grpc-cli prefix=$PKG/usr V=1
-if $(python3 -c 'import Cython' 2>/dev/null); then
- GRPC_PYTHON_BUILD_WITH_CYTHON=True \
- GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=True \
- GRPC_PYTHON_BUILD_SYSTEM_ZLIB=True \
- GRPC_PYTHON_BUILD_SYSTEM_CARES=True \
- CFLAGS="$SLKCFLAGS" \
- python3 setup.py install --root=$PKG
-fi
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true