summaryrefslogtreecommitdiffstats
path: root/libraries/libpgf
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-21 12:03:56 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-21 12:03:56 -0400
commit403812a184b51d11a377ac41503e323b422b6a94 (patch)
tree95247183efe68724386db6e5e358d6baa6f86951 /libraries/libpgf
parent9746a1a4ea625a90ca11a2611f1a5ff2bb548381 (diff)
downloadslackbuilds-403812a184b51d11a377ac41503e323b422b6a94.tar.gz
slackbuilds-403812a184b51d11a377ac41503e323b422b6a94.tar.xz
libraries/libpgf: Remove dos2unix dep; fix docs.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'libraries/libpgf')
-rw-r--r--libraries/libpgf/README2
-rw-r--r--libraries/libpgf/libpgf.SlackBuild35
-rw-r--r--libraries/libpgf/libpgf.info2
3 files changed, 21 insertions, 18 deletions
diff --git a/libraries/libpgf/README b/libraries/libpgf/README
index f2ac974aae..c25e2739b7 100644
--- a/libraries/libpgf/README
+++ b/libraries/libpgf/README
@@ -4,5 +4,3 @@ and lossy compression.
It's considered as one of the best algorithms available these days
for compression of natural images
-
-NOTE: dos2unix is a build-time dependency, not a runtime dependency
diff --git a/libraries/libpgf/libpgf.SlackBuild b/libraries/libpgf/libpgf.SlackBuild
index 09d41001e1..47f5f3c297 100644
--- a/libraries/libpgf/libpgf.SlackBuild
+++ b/libraries/libpgf/libpgf.SlackBuild
@@ -20,11 +20,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220421 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - remove dos2unix dep.
+# - move API docs to correct Slackware doc dir (no more /usr/share/doc).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=libpgf
VERSION=${VERSION:-7.21.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -36,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -73,14 +74,18 @@ cd $PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
sed -i "s|7.15.32|$VERSION|g" configure.ac
touch README
-dos2unix *.{am,ac,in,sh} */*.{am,in}
+
+# 20220421 bkw: perl ships with Slackware, use it instead of dos2unix.
+perl -i -pe 's,\r,,' *.{am,ac,in,sh} */*.{am,in}
+
#sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am
+
autoreconf -i
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -91,20 +96,20 @@ CFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux
make
-make install DESTDIR=$PKG
+make install-strip DESTDIR=$PKG
+gzip -9 $PKG/usr/man/man*/*
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+if [ -e $PKG/usr/share/doc/$PRGNAM-$VERSION ]; then
+ mv $PKG/usr/share/doc/$PRGNAM-$VERSION/html $PKG/usr/doc/$PRGNAM-$VERSION
+fi
+rm -rf $PKG/usr/share
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/libraries/libpgf/libpgf.info b/libraries/libpgf/libpgf.info
index 60e64310b8..4d238cc4ac 100644
--- a/libraries/libpgf/libpgf.info
+++ b/libraries/libpgf/libpgf.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://downloads.sourceforge.net/project/libpgf/libpgf/7.21.7/libpgf.
MD5SUM="6e956fc3575a9047bafc2782ec17041f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="dos2unix"
+REQUIRES=""
MAINTAINER="Willy Sudiarto Raharjo"
EMAIL="willysr@slackbuilds.org"