summaryrefslogtreecommitdiffstats
path: root/libraries/msgpack-c-cpp
diff options
context:
space:
mode:
author Giancarlo Dessi <slack@giand.it>2024-02-23 17:14:04 +0900
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-23 16:37:56 +0700
commita72eb184869aff41d7d2589109b9381a1256736a (patch)
tree4ebb9d44e098734ef37343468f04c57f13e14fbc /libraries/msgpack-c-cpp
parent916c88d679b0bcee0609d78974f3924d4235deb1 (diff)
downloadslackbuilds-a72eb184869aff41d7d2589109b9381a1256736a.tar.gz
slackbuilds-a72eb184869aff41d7d2589109b9381a1256736a.tar.xz
libraries/msgpack-c-cpp: Added (MessagePack implementation for C++).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/msgpack-c-cpp')
-rw-r--r--libraries/msgpack-c-cpp/README21
-rw-r--r--libraries/msgpack-c-cpp/msgpack-c-cpp.SlackBuild120
-rw-r--r--libraries/msgpack-c-cpp/msgpack-c-cpp.info10
-rw-r--r--libraries/msgpack-c-cpp/slack-desc19
4 files changed, 170 insertions, 0 deletions
diff --git a/libraries/msgpack-c-cpp/README b/libraries/msgpack-c-cpp/README
new file mode 100644
index 0000000000..4219870b84
--- /dev/null
+++ b/libraries/msgpack-c-cpp/README
@@ -0,0 +1,21 @@
+MessagePack is an efficient binary serialisation format that lets you
+exchange data among multiple languages like JSON.
+
+Versions later than 3.3.0 have separate C and C++ implementations.
+This slackbuild builds only the C++ implementation of MessagePack as
+header-only library.
+If you need also the C implementation you have to build and install
+the package msgpack-c-c even. Both packages can coexist.
+
+Note: msgpack-c-cpp conflicts with the old msgpack-c package, that
+implements both C and C++ but is based on a old outdated release of
+msgpack-c. If you have msgpack-c version 3.3.0 in your system, please
+remove it before installing these package.
+
+This slackbuild is experimental because some slackbuilds that require
+msgpack-c should be updated. If your installed packages work still with
+the old msgpack-c for version 3.3.0, you should kept it.
+
+At the moment, this package is tested and strictly required by mmtf-cpp,
+other slackbuilds based on msgpack-c could not work with this
+installation.
diff --git a/libraries/msgpack-c-cpp/msgpack-c-cpp.SlackBuild b/libraries/msgpack-c-cpp/msgpack-c-cpp.SlackBuild
new file mode 100644
index 0000000000..6beefdd0d8
--- /dev/null
+++ b/libraries/msgpack-c-cpp/msgpack-c-cpp.SlackBuild
@@ -0,0 +1,120 @@
+#!/bin/bash
+
+# SlackBuild script for msgpack-c-cpp
+
+# Copyright 2024 Giancarlo Dessi, Cagliari, IT
+# Copyright 2021 Ruben Schuller <sb@rbn.im>
+# Copyright 2014-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# 20240224: derived from original script for msgpack-c package
+# 20220419 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - remove empty AUTHORS from doc dir.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=msgpack-c-cpp
+VERSION=${VERSION:-6.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+# msgpack-c and older versions use the same include dirs so them
+# cannot coexist with msgpack-c-cpp
+if pkg-config --exists msgpack; then
+ echo "************************************************************************"
+ echo " WARNING: an old version of msgpack-c has been detected in your system!"
+ echo " This conflicts with msgpack-c-cpp. Please remove old installations of"
+ echo " msgpack-c before installing this package"
+ echo " This script will be stopped"
+ echo "************************************************************************"
+ exit 1
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+sed -i ./CMakeLists.txt -e "s/VERSION 3.1 FATAL_ERROR/VERSION 3.5 FATAL_ERROR/g"
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
+ ..
+ make install/strip DESTDIR=$PKG
+cd ..
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING LICENSE_1_0.txt NOTICE *.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/msgpack-c-cpp/msgpack-c-cpp.info b/libraries/msgpack-c-cpp/msgpack-c-cpp.info
new file mode 100644
index 0000000000..1adc2baa10
--- /dev/null
+++ b/libraries/msgpack-c-cpp/msgpack-c-cpp.info
@@ -0,0 +1,10 @@
+PRGNAM="msgpack-c-cpp"
+VERSION="6.1.0"
+HOMEPAGE="https://github.com/msgpack/msgpack-c"
+DOWNLOAD="https://github.com/msgpack/msgpack-c/archive/cpp-6.1.0/cpp-6.1.0.tar.gz"
+MD5SUM="42cce30906229fc124bac04c502f1241"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Giancarlo Dessi"
+EMAIL="slack@giand.it"
diff --git a/libraries/msgpack-c-cpp/slack-desc b/libraries/msgpack-c-cpp/slack-desc
new file mode 100644
index 0000000000..4e2b44e28b
--- /dev/null
+++ b/libraries/msgpack-c-cpp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+msgpack-c-cpp: msgpack-c-cpp (C++ implementation of MessagePack)
+msgpack-c-cpp:
+msgpack-c-cpp: msgpack-c-cpp is a C++ header-only implementation of MessagePack,
+msgpack-c-cpp: a binary serialisation format.
+msgpack-c-cpp: This package does not include the C implementation.
+msgpack-c-cpp:
+msgpack-c-cpp:
+msgpack-c-cpp: Home page: https://github.com/msgpack/msgpack-c
+msgpack-c-cpp:
+msgpack-c-cpp:
+msgpack-c-cpp: