summaryrefslogtreecommitdiffstats
path: root/libraries/python3-plumbum/python3-plumbum.SlackBuild
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-01-04 16:48:01 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-01-07 08:13:30 +0700
commit6f5e5defc1ae495172c0e994277ef81d4efd5f77 (patch)
treed581584c02f0b3e3c571d669ff25427bcfc01f68 /libraries/python3-plumbum/python3-plumbum.SlackBuild
parent5589356a8a23fc314091cab0b626ae020c1ca279 (diff)
downloadslackbuilds-6f5e5defc1ae495172c0e994277ef81d4efd5f77.tar.gz
slackbuilds-6f5e5defc1ae495172c0e994277ef81d4efd5f77.tar.xz
libraries/python3-plumbum: Updated for version 1.8.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/python3-plumbum/python3-plumbum.SlackBuild')
-rw-r--r--libraries/python3-plumbum/python3-plumbum.SlackBuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/libraries/python3-plumbum/python3-plumbum.SlackBuild b/libraries/python3-plumbum/python3-plumbum.SlackBuild
index 679a0d6120..04a8fa24b6 100644
--- a/libraries/python3-plumbum/python3-plumbum.SlackBuild
+++ b/libraries/python3-plumbum/python3-plumbum.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-plumbum
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230104 46and2: Updated version, build system changed.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-plumbum
SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-1.8.0}
+VERSION=${VERSION:-1.8.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,11 +75,12 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true