summaryrefslogtreecommitdiffstats
path: root/network/weechat
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-09-08 04:03:27 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-09 10:14:22 +0700
commit2eeff6423874102625323ed26cf66ec3115b6fe4 (patch)
tree7d80d3d03b7aaa3884a1b1f955aa09250ccde104 /network/weechat
parentf76d32220a663c1655096a2f4dcadc1f6409e5d8 (diff)
downloadslackbuilds-2eeff6423874102625323ed26cf66ec3115b6fe4.tar.gz
slackbuilds-2eeff6423874102625323ed26cf66ec3115b6fe4.tar.xz
network/weechat: Updated for version 4.0.4.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/weechat')
-rw-r--r--network/weechat/README31
-rw-r--r--network/weechat/weechat.SlackBuild19
-rw-r--r--network/weechat/weechat.info6
3 files changed, 31 insertions, 25 deletions
diff --git a/network/weechat/README b/network/weechat/README
index 9a48d35a31..0acafadeb3 100644
--- a/network/weechat/README
+++ b/network/weechat/README
@@ -4,21 +4,24 @@ WeeChat is a light, fast, multilingual, curses-based multiplatform
IRC client.
WeeChat supports:
-- DCC files and chats, multi-server connections, background connections,
-- IPv6, SSL, proxy, auto-reconnection, DCC2, nicklist, window splitting,
-- FIFO pipe for remote control, Aspell, JavaScript[1], Perl, Python,
- Ruby, nick auto-completion, lag indication, auto-logging and client
- upgrades without dropping connections.
+- DCC files and chats, multi-server connections, background connections.
+- IPv6, SSL, proxy, auto-reconnection, DCC2, nicklist, window splitting.
+- FIFO pipe for remote control; Aspell; scripting in Perl, Python 3,
+ Ruby, Tcl, Scheme, Lua[1], JavaScript[2], PHP[3]; nick
+ auto-completion; lag indication; auto-logging; and client upgrades
+ without dropping connections.
-WeeChat will be built with support for Perl, Python, Guile, Ruby,
-and Tcl scripting. Once WeeChat is running, you can install scripts
+WeeChat will be built with support for Perl, Python 3, Guile, Ruby,
+and Tcl scripting[1]. Once WeeChat is running, you can install scripts
using the built-in script manager ("/help script" to get started).
-Optional dependencies: lua53, lua53, or lua. If one or more of
-these are installed, Lua scripting support will also be included. The
-highest-numbered version of lua will be used, if multiple versions are
-installed.
+[1] To enable Lua scripting, install one of these optional dependencies:
+ lua53, lua52, or lua. The highest-numbered version of lua will be
+ used, if multiple versions are installed.
-[1] JavaScript is not currently supported in this build of WeeChat. It
-also isn't supported in Debian's weechat package, for what that's
-worth.
+[2] JavaScript is not currently supported in this build of WeeChat. It
+ also isn't supported in Debian's set of weechat packages, for what
+ that's worth.
+
+[3] PHP is not supported in this SlackBuild because Slackware's php
+ package isn't built with --enable-embed.
diff --git a/network/weechat/weechat.SlackBuild b/network/weechat/weechat.SlackBuild
index adb53d094e..f691083eff 100644
--- a/network/weechat/weechat.SlackBuild
+++ b/network/weechat/weechat.SlackBuild
@@ -23,6 +23,7 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230907 bkw: update for v4.0.4.
# 20230104 bkw: update for v3.7.1.
# 20211019 bkw:
@@ -43,7 +44,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=weechat
-VERSION=${VERSION:-3.7.1}
+VERSION=${VERSION:-4.0.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -85,24 +86,24 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
# 20211019 bkw: patch from Debian: Build html documentation without
# requiring data (javascript, fonts) on external websites (potential
# privacy breach). Patch was slightly modified for Slackware.
# 20230104 bkw: patch updated, used as-is from Debian this time.
-patch -p1 < $CWD/01_fix_asciidoctor_options.patch
+#patch -p1 < $CWD/01_fix_asciidoctor_options.patch
# 20211019 bkw: hardcoded paths suck.
DOC=/usr/doc/$PRGNAM-$VERSION
PKGDOC=$PKG/$DOC
sed -i \
- '/install(/s,\(DESTINATION\) *\$.DATAROOTDIR.*,\1 '$DOC'/html),' \
- doc/*/CMakeLists.txt
+ '/install(/s,\(DESTINATION\) *"\$.DATAROOTDIR.*,\1 '$DOC'/html),' \
+ doc/CMakeLists.txt
# 20211019 bkw:
# -DENABLE_PHP=OFF because Slackware's php isn't built with --enable-embed.
@@ -118,7 +119,8 @@ for i in lua5.3 lua5.2 lua; do
done
# Everything else is autodetected and/or included in a full Slackware
-# install.
+# install. Have to enable "incomplete docs" in 4.0.x, so it won't
+# complain about disabled plugins.
mkdir build
cd build
@@ -130,6 +132,7 @@ cd build
-DENABLE_JAVASCRIPT=OFF \
-DENABLE_PHP=OFF \
-DENABLE_DOC=ON \
+ -DENABLE_DOC_INCOMPLETE=ON \
-DENABLE_MAN=ON \
-DMANDIR=/usr/man \
-DLIBDIR=/usr/lib${LIBDIRSUFFIX} \
diff --git a/network/weechat/weechat.info b/network/weechat/weechat.info
index 1c7d6d738e..152c65a696 100644
--- a/network/weechat/weechat.info
+++ b/network/weechat/weechat.info
@@ -1,8 +1,8 @@
PRGNAM="weechat"
-VERSION="3.7.1"
+VERSION="4.0.4"
HOMEPAGE="https://www.weechat.org"
-DOWNLOAD="https://weechat.org/files/src/weechat-3.7.1.tar.bz2"
-MD5SUM="f7f1821ebaad26079de00bc030c19ad6"
+DOWNLOAD="https://weechat.org/files/src/weechat-4.0.4.tar.xz"
+MD5SUM="02fb749061325aaaf2afde97b3e98e10"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""