summaryrefslogtreecommitdiffstats
path: root/python/python3-WTForms
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-10-10 19:19:31 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-14 10:32:31 +0700
commit2212099a542b3ff9d805a3a3cf60a7c577adbd93 (patch)
tree1c66cc4c01e7f74166e7849c706fc6207df1928f /python/python3-WTForms
parent69af6f916f216f4e43ad1f4b54d92fe2c76e9626 (diff)
downloadslackbuilds-2212099a542b3ff9d805a3a3cf60a7c577adbd93.tar.gz
slackbuilds-2212099a542b3ff9d805a3a3cf60a7c577adbd93.tar.xz
python/python3-WTForms: Updated for version 3.1.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-WTForms')
-rw-r--r--python/python3-WTForms/python3-WTForms.SlackBuild34
-rw-r--r--python/python3-WTForms/python3-WTForms.info8
2 files changed, 14 insertions, 28 deletions
diff --git a/python/python3-WTForms/python3-WTForms.SlackBuild b/python/python3-WTForms/python3-WTForms.SlackBuild
index 7f73fb7629..a3b4bbe41f 100644
--- a/python/python3-WTForms/python3-WTForms.SlackBuild
+++ b/python/python3-WTForms/python3-WTForms.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-WTForms
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20231010 46and2: Updated version, changed to pep517 build.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-WTForms
-SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-3.0.1}
+SRCNAM=wtforms
+VERSION=${VERSION:-3.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,36 +50,23 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz --exclude=.hgignore
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-WTForms/python3-WTForms.info b/python/python3-WTForms/python3-WTForms.info
index a504fa5632..da306b904c 100644
--- a/python/python3-WTForms/python3-WTForms.info
+++ b/python/python3-WTForms/python3-WTForms.info
@@ -1,10 +1,10 @@
PRGNAM="python3-WTForms"
-VERSION="3.0.1"
+VERSION="3.1.0"
HOMEPAGE="http://wtforms.simplecodes.com/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/w/wtforms/WTForms-3.0.1.tar.gz"
-MD5SUM="509a985769df13938c8307b55a614773"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/w/wtforms/wtforms-3.1.0.tar.gz"
+MD5SUM="a07a4a149eec493c6cc614ee20aed8a0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-babel"
+REQUIRES="python3-hatchling python3-babel"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"