summaryrefslogtreecommitdiffstats
path: root/python/python3-kombu
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-03-08 20:17:32 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 09:34:54 +0700
commit9ce37db212d37691272b60a77554e8d7e9a97a18 (patch)
treec0d3b4d161d61c53d11ec8ace52b3ea395e1bef2 /python/python3-kombu
parent225e89010a7b2316d4fb91e92f74a3929d2b042c (diff)
downloadslackbuilds-9ce37db212d37691272b60a77554e8d7e9a97a18.tar.gz
slackbuilds-9ce37db212d37691272b60a77554e8d7e9a97a18.tar.xz
python/python3-kombu: renamed from kombu for python3, updated for version 5.2.3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-kombu')
-rw-r--r--python/python3-kombu/README9
-rw-r--r--python/python3-kombu/python3-kombu.SlackBuild77
-rw-r--r--python/python3-kombu/python3-kombu.info10
-rw-r--r--python/python3-kombu/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/python3-kombu/README b/python/python3-kombu/README
new file mode 100644
index 0000000000..7df1347cb3
--- /dev/null
+++ b/python/python3-kombu/README
@@ -0,0 +1,9 @@
+Kombu is a messaging library for Python.
+
+The aim of Kombu is to make messaging in Python as easy as possible by
+providing an idiomatic high-level interface for the AMQ protocol, and
+also provide proven and tested solutions to common messaging problems.
+
+AMQP is the Advanced Message Queuing Protocol, an open standard protocol
+for message orientation, queuing, routing, reliability and security, for
+which the RabbitMQ messaging server is the most popular implementation.
diff --git a/python/python3-kombu/python3-kombu.SlackBuild b/python/python3-kombu/python3-kombu.SlackBuild
new file mode 100644
index 0000000000..d14251e963
--- /dev/null
+++ b/python/python3-kombu/python3-kombu.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# SlackBuild script for kombu.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-kombu
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-5.2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-kombu/python3-kombu.info b/python/python3-kombu/python3-kombu.info
new file mode 100644
index 0000000000..afcc8b7ba6
--- /dev/null
+++ b/python/python3-kombu/python3-kombu.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-kombu"
+VERSION="5.2.3"
+HOMEPAGE="https://kombu.readthedocs.io/"
+DOWNLOAD="https://pypi.python.org/packages/source/k/kombu/kombu-5.2.3.tar.gz"
+MD5SUM="bfa2d216e777ecd9dc8375cd89e742cf"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-amqp vine"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-kombu/slack-desc b/python/python3-kombu/slack-desc
new file mode 100644
index 0000000000..4b85f989b8
--- /dev/null
+++ b/python/python3-kombu/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-kombu: python3-kombu (messaging library for Python)
+python3-kombu:
+python3-kombu: The aim of Kombu is to make messaging in Python as easy as possible
+python3-kombu: by providing an idiomatic high-level interface for the AMQ protocol,
+python3-kombu: and also provide proven and tested solutions to common messaging
+python3-kombu: problems.
+python3-kombu:
+python3-kombu:
+python3-kombu:
+python3-kombu:
+python3-kombu: