summaryrefslogtreecommitdiffstats
path: root/games/nethack/patches/Makefile_src.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/nethack/patches/Makefile_src.patch')
-rw-r--r--games/nethack/patches/Makefile_src.patch83
1 files changed, 83 insertions, 0 deletions
diff --git a/games/nethack/patches/Makefile_src.patch b/games/nethack/patches/Makefile_src.patch
new file mode 100644
index 0000000000..1e304a2427
--- /dev/null
+++ b/games/nethack/patches/Makefile_src.patch
@@ -0,0 +1,83 @@
+--- sys/unix/Makefile.src 2003-12-07 17:39:13.000000000 -0600
++++ sys/unix/Makefile.src.slack 2008-05-15 15:29:14.000000000 -0500
+@@ -61,7 +61,7 @@
+ # if you get setcgtty() warnings during execution, you are feeding gcc
+ # a non-ANSI <sys/ioctl.h> -- either run fixincludes on it or use
+ # -traditional in CFLAGS
+-# CC = gcc
++CC = gcc
+ #
+ # For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
+ #
+@@ -125,7 +125,7 @@
+ # flags for Linux
+ # compile normally
+ # CFLAGS = -O2 -fomit-frame-pointer -I../include
+-# LFLAGS = -L/usr/X11R6/lib
++LFLAGS = -L/usr/lib
+ # OR compile backwards compatible a.out format
+ # CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
+ # LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
+@@ -186,7 +186,8 @@
+ # Files for a Qt port
+ #
+ WINQTSRC = ../win/Qt/qt_win.cpp ../win/Qt/qt_clust.cpp ../win/Qt/qttableview.cpp
+-WINQTOBJ = qt_win.o qt_clust.o qttableview.o tile.o
++# WINQTOBJ = qt_win.o qt_clust.o qttableview.o tile.o
++WINQTOBJ = qt_win.o qt_clust.o qttableview.o
+ #
+ # Files for a Gnome port
+ #
+@@ -214,8 +215,8 @@
+
+ #
+ #
+-WINSRC = $(WINTTYSRC)
+-WINOBJ = $(WINTTYOBJ)
++WINSRC = $(WINTTYSRC) $(WINX11SRC) $(WINQTSRC) $(WINKDESRC)
++WINOBJ = $(WINTTYOBJ) $(WINX11OBJ) $(WINQTOBJ) $(WINKDEOBJ)
+
+ # on some systems the termcap library is in -ltermcap or -lcurses
+ # on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
+@@ -230,18 +231,19 @@
+ # WINTTYLIB = -ltermcap
+ # WINTTYLIB = -lcurses
+ # WINTTYLIB = -lcurses16
+-# WINTTYLIB = -lncurses
+-WINTTYLIB = -ltermlib
++WINTTYLIB = -lncurses
++# WINTTYLIB = -ltermlib
+ #
+ # libraries for X11
+ # If USE_XPM is defined in config.h, you will also need -lXpm here.
+-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
++# WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
+ # WINX11LIB = -lXaw -lXmu -lXt -lX11
+ # WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
+ # WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
++WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11
+ #
+ # libraries for Qt
+-WINQTLIB = -L$(QTDIR)/lib -lqt
++WINQTLIB = -L$(QTDIR)/lib -lqt-mt
+ #
+ # libraries for KDE (with Qt)
+ WINKDELIB = -lkdecore -lkdeui -lXext
+@@ -255,7 +257,7 @@
+ # libraries for BeOS
+ WINBELIB = -lbe
+
+-WINLIB = $(WINTTYLIB)
++WINLIB = $(WINTTYLIB) $(WINX11LIB) $(WINQTLIB) $(WINKDELIB)
+
+ # any other strange libraries your system needs (for Sysunix only -- the more
+ # specialized targets should already be right)
+@@ -295,7 +297,7 @@
+
+
+ # used by `make depend' to reconstruct this Makefile; you shouldn't need this
+-AWK = nawk
++AWK = gawk
+
+ # ----------------------------------------
+ #