summaryrefslogtreecommitdiffstats
path: root/source/d/python-setuptools/python-setuptools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/python-setuptools/python-setuptools.SlackBuild')
-rwxr-xr-xsource/d/python-setuptools/python-setuptools.SlackBuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/source/d/python-setuptools/python-setuptools.SlackBuild b/source/d/python-setuptools/python-setuptools.SlackBuild
index 694f68ac4..e01f11a7c 100755
--- a/source/d/python-setuptools/python-setuptools.SlackBuild
+++ b/source/d/python-setuptools/python-setuptools.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 2013-2014 Audrius Kažukauskas <audrius@neutrino.lt>
-# Copyright 2014, 2017, 2018, 2022 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2014, 2017, 2018, 2022, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -99,7 +99,9 @@ if [ "$LIBDIRSUFFIX" = "64" ]; then
zcat $CWD/setuptools.x86_64.diff.gz | patch -p1 --verbose || exit 1
fi
-python3 setup.py install --root=$PKG || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a CHANGES.rst PKG-INFO README.rst docs/*.txt \