summaryrefslogtreecommitdiffstats
path: root/source/l/python-cffi/python-cffi.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-cffi/python-cffi.SlackBuild')
-rwxr-xr-xsource/l/python-cffi/python-cffi.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/source/l/python-cffi/python-cffi.SlackBuild b/source/l/python-cffi/python-cffi.SlackBuild
index 8cb165ecf..42891abf8 100755
--- a/source/l/python-cffi/python-cffi.SlackBuild
+++ b/source/l/python-cffi/python-cffi.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2021 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2021, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=python-cffi
SRCNAM=cffi
VERSION=${VERSION:-$(echo ${SRCNAM}-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-1}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -59,7 +59,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a AUTHORS* LICENSE* PKG-INFO* README* \