summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2024-04-29 16:32:08 -0600
committer fourtysixandtwo <fourtysixandtwo@sliderr.net>2024-04-29 16:35:06 -0600
commit18ec412cf980a6414dba4a197eb971abe9958214 (patch)
tree519c45a53858226de9fdffa735ec5b73cdc898df
parent68ac93024440c1dcb61e579018ce241a1ab44180 (diff)
downloadslackbuilds-user/46and2/updates.tar.gz
slackbuilds-user/46and2/updates.tar.xz
system/Solaar: Fix building on -current.user/46and2/updates
With permission from Erich.
-rw-r--r--system/Solaar/Solaar.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/system/Solaar/Solaar.SlackBuild b/system/Solaar/Solaar.SlackBuild
index e7d077043f..b739b40052 100644
--- a/system/Solaar/Solaar.SlackBuild
+++ b/system/Solaar/Solaar.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Solaar
VERSION=${VERSION:-1.1.11}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -68,7 +68,11 @@ find -L . \
python3 setup.py install --root=$PKG
-mv $PKG/usr/lib $PKG/
+# 20240429 46and2: make sure to only move the udev dir to $PKG/lib/
+# and remove $PKG/usr/lib if empty.
+mkdir $PKG/lib
+mv $PKG/usr/lib/udev $PKG/lib/
+rmdir --ignore-fail-on-non-empty $PKG/usr/lib
sed -i 's/#MODE="0660", GROUP="plugdev"/MODE="0660", GROUP="plugdev"/g' $PKG/lib/udev/rules.d/42-logitech-unify-permissions.rules
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION