summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2024-05-06 02:35:03 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-11 08:12:32 +0700
commit593550abc77f32620f0fc5ee322db824b1d3d54b (patch)
tree6bf95261474c3c127be4102dbd4e4a7afea7d32d
parentfbf5d8e35fd18569babfcb2cd7ee63bfe9038fe8 (diff)
downloadslackbuilds-593550abc77f32620f0fc5ee322db824b1d3d54b.tar.gz
slackbuilds-593550abc77f32620f0fc5ee322db824b1d3d54b.tar.xz
development/atasm: Updated for version 1.25.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/atasm/0001-Fix-the-compiling-under-Linux-Mac.patch34
-rw-r--r--development/atasm/README5
-rw-r--r--development/atasm/atasm.SlackBuild15
-rw-r--r--development/atasm/atasm.info6
-rw-r--r--development/atasm/gcc11fix.diff26
5 files changed, 75 insertions, 11 deletions
diff --git a/development/atasm/0001-Fix-the-compiling-under-Linux-Mac.patch b/development/atasm/0001-Fix-the-compiling-under-Linux-Mac.patch
new file mode 100644
index 0000000000..ec9a977b92
--- /dev/null
+++ b/development/atasm/0001-Fix-the-compiling-under-Linux-Mac.patch
@@ -0,0 +1,34 @@
+From 08296d7cc2697696f2e6098e619f316baaebc626 Mon Sep 17 00:00:00 2001
+From: CycoZA <peter@cerebus.co.za>
+Date: Sun, 5 May 2024 16:29:52 +0200
+Subject: [PATCH] Fix the compiling under Linux/Mac
+
+---
+ src/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 74971d1..d0b5cff 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -19,7 +19,7 @@ UNIX = -DUNIX
+ #CFLAGS = -g -Wall $(USEZ) $(DOS) $(UNIX) $(ARCH)
+ CFLAGS = -Wall $(USEZ) $(DOS) $(UNIX) -O3 -fomit-frame-pointer $(ARCH)
+
+-L = $(ZLIB)
++L = $(ZLIB) -lm
+ CC = gcc
+ DESTDIR = /usr/local/bin
+ MANDIR = /usr/local/man/man1
+@@ -30,7 +30,7 @@ DOCDIR = /usr/local/doc/atasm
+
+ all: prog
+
+-OBJS = asm.o symbol.o parser.o setparse.o state.o dimage.o inc_path.o crc32.o atasm_err.o state2.o
++OBJS = asm.o symbol.o parser.o setparse.o state.o dimage.o inc_path.o crc32.o atasm_err.o state2.o parse_float.o setfloatparse.o
+
+ asm.o: ops.h directive.h symbol.h inc_path.h atasm_err.h
+ atasm_err.o: atasm_err.h symbol.h
+--
+2.35.8
+
diff --git a/development/atasm/README b/development/atasm/README
index 5a818ce548..92865c4ed1 100644
--- a/development/atasm/README
+++ b/development/atasm/README
@@ -4,8 +4,3 @@ ATasm is a 6502 command-line cross-assembler that is compatible with
the original Mac/65 macroassembler released by OSS software. Code
development can now be performed using modern editors and compiles with
lightning speed.
-
-This build has been updated for version 1.07d (the last beta
-release), but it's still possible to build 1.06 (last stable release)
-by downloading the 1.06 source and setting VERSION=1.06 in the
-environment.
diff --git a/development/atasm/atasm.SlackBuild b/development/atasm/atasm.SlackBuild
index 7923307007..3079667d35 100644
--- a/development/atasm/atasm.SlackBuild
+++ b/development/atasm/atasm.SlackBuild
@@ -6,6 +6,8 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20240505 bkw: update for v1.25.
+
# 20240207 bkw:
# - update for v1.23, which is a maintained fork from a new dev.
@@ -18,7 +20,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=atasm
-VERSION=${VERSION:-1.23}
+VERSION=${VERSION:-1.25}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -60,8 +62,15 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz \
--exclude='*.exe' --exclude='*.sln' --exclude="*.vcx*"
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+
+# this patch is from upstream git.
+patch -p1 < $CWD/0001-Fix-the-compiling-under-Linux-Mac.patch
+
+# this patch has been submitted to upstream, should be in the next
+# release.
+patch -p1 < $CWD/gcc11fix.diff
DOCDIR=/usr/doc/$PRGNAM-$VERSION
diff --git a/development/atasm/atasm.info b/development/atasm/atasm.info
index 73aee354f6..66fac87aa8 100644
--- a/development/atasm/atasm.info
+++ b/development/atasm/atasm.info
@@ -1,8 +1,8 @@
PRGNAM="atasm"
-VERSION="1.23"
+VERSION="1.25"
HOMEPAGE="https://github.com/CycoPH/atasm/"
-DOWNLOAD="https://github.com/CycoPH/atasm/archive/V1.23/atasm-1.23.tar.gz"
-MD5SUM="8530e6c68b9c0d68dee592ac24f0b247"
+DOWNLOAD="https://github.com/CycoPH/atasm/archive/V1.25/atasm-1.25.tar.gz"
+MD5SUM="566b3c902941210966dc02ee0606b853"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/development/atasm/gcc11fix.diff b/development/atasm/gcc11fix.diff
new file mode 100644
index 0000000000..e3f7946d75
--- /dev/null
+++ b/development/atasm/gcc11fix.diff
@@ -0,0 +1,26 @@
+diff --git a/src/setfloatparse.c b/src/setfloatparse.c
+index 3bf78b8..61c1569 100644
+--- a/src/setfloatparse.c
++++ b/src/setfloatparse.c
+@@ -41,7 +41,7 @@ float fnums[64];
+ extern int get_dotname(char* src, char* dst);
+ extern symbol* validate_symbol(char* str);
+
+-char* parse_string;
++static char* parse_string;
+ /*=========================================================================*
+ function floatlex()
+
+diff --git a/src/setparse.c b/src/setparse.c
+index 07904c5..fb4fc66 100644
+--- a/src/setparse.c
++++ b/src/setparse.c
+@@ -36,7 +36,7 @@ int yyparse();
+ extern int rval;
+ int vnum, nums[64];
+
+-char *parse_string;
++static char *parse_string;
+ /*=========================================================================*
+ function yylex()
+