summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2022-12-03 11:33:17 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-03 11:33:17 +0700
commitc041f335efecffdf7cd90f9c30057f580f4b8cbb (patch)
treea016a867bc39fe3fc4e5b57c5531b47223c3ec85
parent5149d3f60bae9e306606445b462b449c126d8b8a (diff)
downloadslackbuilds-c041f335efecffdf7cd90f9c30057f580f4b8cbb.tar.gz
slackbuilds-c041f335efecffdf7cd90f9c30057f580f4b8cbb.tar.xz
python/python3-jsonschema: Updated for version 4.17.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-jsonschema/python3-jsonschema.SlackBuild16
-rw-r--r--python/python3-jsonschema/python3-jsonschema.info12
-rw-r--r--python/python3-jsonschema/slack-desc2
3 files changed, 15 insertions, 15 deletions
diff --git a/python/python3-jsonschema/python3-jsonschema.SlackBuild b/python/python3-jsonschema/python3-jsonschema.SlackBuild
index 9063513500..4cf1035aff 100644
--- a/python/python3-jsonschema/python3-jsonschema.SlackBuild
+++ b/python/python3-jsonschema/python3-jsonschema.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for python3-jsonschema
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# Based on jsonschema by Dimitris Zlatanidis
# All rights reserved.
@@ -23,16 +24,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20221128 46and2: Updated version, new maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-jsonschema
-VERSION=${VERSION:-3.2.0}
+SRCNAM=$(echo $PRGNAM | sed -e "s/python3-//")
+VERSION=${VERSION:-4.17.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM=jsonschema
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -41,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,9 +79,10 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-jsonschema/python3-jsonschema.info b/python/python3-jsonschema/python3-jsonschema.info
index d5976ba97b..60c346db9d 100644
--- a/python/python3-jsonschema/python3-jsonschema.info
+++ b/python/python3-jsonschema/python3-jsonschema.info
@@ -1,10 +1,10 @@
PRGNAM="python3-jsonschema"
-VERSION="3.2.0"
+VERSION="4.17.3"
HOMEPAGE="https://github.com/Julian/jsonschema"
-DOWNLOAD="https://pypi.python.org/packages/source/j/jsonschema/jsonschema-3.2.0.tar.gz"
-MD5SUM="f1a0b5011f05a02a8dee1070cd10a26d"
+DOWNLOAD="https://pypi.python.org/packages/source/j/jsonschema/jsonschema-4.17.3.tar.gz"
+MD5SUM="7c65ceb8923c83cb1f22c2b5a86d99b0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-importlib_metadata python3-attrs python3-pyrsistent"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="python-importlib_metadata python3-attrs python3-pyrsistent python3-hatch_vcs python3-hatch_fancy_pypi_readme"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-jsonschema/slack-desc b/python/python3-jsonschema/slack-desc
index 19999a7232..24fc8a17f0 100644
--- a/python/python3-jsonschema/slack-desc
+++ b/python/python3-jsonschema/slack-desc
@@ -11,7 +11,7 @@ python3-jsonschema:
python3-jsonschema: jsonschema is an implementation of JSON Schema
python3-jsonschema: for Python (supporting Python 3).
python3-jsonschema:
-python3-jsonschema:
+python3-jsonschema: Homepage: https://github.com/python-jsonschema/jsonschema
python3-jsonschema:
python3-jsonschema:
python3-jsonschema: