summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-05-15 22:18:57 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:40 +0700
commitd167a1d0be59ad5286a9af7919135ce3ef09d828 (patch)
treec77cf2d5162a64b2e8d3d0ff405dca8bbe84a0cd
parentb48b38dce5f7d2d7f9ebc70d074cd05f4a8b1ce1 (diff)
downloadslackbuilds-d167a1d0be59ad5286a9af7919135ce3ef09d828.tar.gz
slackbuilds-d167a1d0be59ad5286a9af7919135ce3ef09d828.tar.xz
python/sphinx-rtd-theme: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild b/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild
index dcbab0d22d..9c527dde6d 100644
--- a/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild
+++ b/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild
@@ -40,15 +40,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -67,14 +64,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
-fi
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
+
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION