summaryrefslogtreecommitdiffstats
path: root/academic/bowtie/patches/disable_bits_flag.patch
diff options
context:
space:
mode:
author Petar Petrov <petar.petrov@student.oulu.fi>2013-12-14 07:31:21 +0700
committer Erik Hanson <erik@slackbuilds.org>2013-12-14 10:53:05 -0600
commit70013017755f78c0636a880522351dc5b588277e (patch)
treeeac41e23ff997e41eb9b813e8fed747f6d8ac8ea /academic/bowtie/patches/disable_bits_flag.patch
parentca3a131931b1c0a9fca77630daddd3349048a569 (diff)
downloadslackbuilds-70013017755f78c0636a880522351dc5b588277e.tar.gz
slackbuilds-70013017755f78c0636a880522351dc5b588277e.tar.xz
academic/bowtie: Updated for version 1.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/bowtie/patches/disable_bits_flag.patch')
-rw-r--r--academic/bowtie/patches/disable_bits_flag.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/academic/bowtie/patches/disable_bits_flag.patch b/academic/bowtie/patches/disable_bits_flag.patch
new file mode 100644
index 0000000000..3d849240e7
--- /dev/null
+++ b/academic/bowtie/patches/disable_bits_flag.patch
@@ -0,0 +1,20 @@
+Description: Disable architecture bits detection.
+ In Debian, you can use multiarch facilities for choosing which version
+ to run.
+Author: Ognyan Kulev <ogi@debian.org>
+Forwarded: not-needed
+Last-Update: 2013-04-24
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- bowtie-1.0.0.orig/Makefile
++++ bowtie-1.0.0/Makefile
+@@ -121,6 +121,9 @@
+ BITS_FLAG = -m64
+ endif
+
++# Debian: Disable selection of 32/64-bits. Use multiarch instead.
++BITS_FLAG =
++
+ DEBUG_FLAGS = -O0 -g3 $(BITS_FLAG)
+ RELEASE_FLAGS = -O3 $(BITS_FLAG)
+ NOASSERT_FLAGS = -DNDEBUG