summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2024-03-14 02:13:40 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-03-16 10:22:21 +0700
commit9459dc898909a4fe14f8ac2ac6b50e21e7533a83 (patch)
treeca8bcdb23fd4c92ed019cfd062e1f7578222e9a1 /audio
parent51737cd7c26703c41d88afa4fcb1085aaf171fbc (diff)
downloadslackbuilds-9459dc898909a4fe14f8ac2ac6b50e21e7533a83.tar.gz
slackbuilds-9459dc898909a4fe14f8ac2ac6b50e21e7533a83.tar.xz
audio/milkytracker: Fix conflict with rtmidi.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/milkytracker/milkytracker.SlackBuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/audio/milkytracker/milkytracker.SlackBuild b/audio/milkytracker/milkytracker.SlackBuild
index 81abb9e4b6..aa45f84bd8 100644
--- a/audio/milkytracker/milkytracker.SlackBuild
+++ b/audio/milkytracker/milkytracker.SlackBuild
@@ -23,6 +23,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240314 bkw: Modified by SlackBuilds.org:
+# Since we now have rtmidi in the repo, milkytracker autodetects it
+# and tries to build with support for it... which fails (maybe it's
+# too new a version of rtmidi). Since this never had MIDI support
+# before, I've disabled rtmidi autodetection so it'll always build
+# without it. Proper solution would be to patch milkytracker to work
+# with the rtmidi in our repo; I leave that for the maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=milkytracker
@@ -40,9 +48,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -77,9 +82,13 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} +
+
+# 20240314 bkw: it autodetects rtmidi, but fails to build if it does.
+# don't see a clean way to disable rtmidi, so do it dirty:
+sed -i '/find_package(RTMIDI/s,^,#,' CMakeLists.txt
mkdir -p build
cd build