summaryrefslogtreecommitdiffstats
path: root/desktop/nwg-clipman
diff options
context:
space:
mode:
author Jay Lanagan <j@lngn.net>2024-01-12 12:22:59 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-12 12:55:44 +0700
commita8454f9bb9fb5137259596f3ef72fffae259b2c8 (patch)
tree3fed81ec0a295960cdbbdcc9f463924c7a07ca02 /desktop/nwg-clipman
parent183f44f3f115244555cdb6db9cc8b3085837e2b6 (diff)
downloadslackbuilds-a8454f9bb9fb5137259596f3ef72fffae259b2c8.tar.gz
slackbuilds-a8454f9bb9fb5137259596f3ef72fffae259b2c8.tar.xz
desktop/nwg-clipman: Added (a GTK3-based GUI for cliphist).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/nwg-clipman')
-rw-r--r--desktop/nwg-clipman/README7
-rw-r--r--desktop/nwg-clipman/doinst.sh9
-rw-r--r--desktop/nwg-clipman/nwg-clipman.SlackBuild106
-rw-r--r--desktop/nwg-clipman/nwg-clipman.info10
-rw-r--r--desktop/nwg-clipman/slack-desc19
5 files changed, 151 insertions, 0 deletions
diff --git a/desktop/nwg-clipman/README b/desktop/nwg-clipman/README
new file mode 100644
index 0000000000..a669c34045
--- /dev/null
+++ b/desktop/nwg-clipman/README
@@ -0,0 +1,7 @@
+nwg-clipman (a GTK3-based GUI for cliphist)
+
+Nwg-clipman is a GTK3-based GUI for Senan Kelly's cliphist. It
+provides access to previously copied items, as well as management of
+the clipboard history from a window opened on gtk-layer-shell. The
+program is intended for use with sway, Hyprland and other
+wlroots-based Wayland compositors.
diff --git a/desktop/nwg-clipman/doinst.sh b/desktop/nwg-clipman/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/desktop/nwg-clipman/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/desktop/nwg-clipman/nwg-clipman.SlackBuild b/desktop/nwg-clipman/nwg-clipman.SlackBuild
new file mode 100644
index 0000000000..a45e99cf40
--- /dev/null
+++ b/desktop/nwg-clipman/nwg-clipman.SlackBuild
@@ -0,0 +1,106 @@
+#!/bin/bash
+
+# Slackware build script for nwg-clipman
+
+# Copyright 2024 Jay Lanagan (j@lngn.net), Detroit, MI, USA.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=nwg-clipman
+VERSION=${VERSION:-0.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --optimize=1 --root=$PKG
+
+install -Dm0644 -t $PKG/usr/share/pixmaps nwg-clipman.svg
+install -Dm0644 -t $PKG/usr/share/applications nwg-clipman.desktop
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/nwg-clipman/nwg-clipman.info b/desktop/nwg-clipman/nwg-clipman.info
new file mode 100644
index 0000000000..2a712cfe29
--- /dev/null
+++ b/desktop/nwg-clipman/nwg-clipman.info
@@ -0,0 +1,10 @@
+PRGNAM="nwg-clipman"
+VERSION="0.1.0"
+HOMEPAGE="https://nwg-piotr.github.io/nwg-clipman/"
+DOWNLOAD="https://github.com/nwg-piotr/nwg-clipman/archive/v0.1.0/nwg-clipman-0.1.0.tar.gz"
+MD5SUM="0b1b4c811a354c9240d5fc075756ee18"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="cliphist gtk-layer-shell"
+MAINTAINER="Jay Lanagan"
+EMAIL="j@lngn.net"
diff --git a/desktop/nwg-clipman/slack-desc b/desktop/nwg-clipman/slack-desc
new file mode 100644
index 0000000000..6fd789f220
--- /dev/null
+++ b/desktop/nwg-clipman/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+nwg-clipman: nwg-clipman (a GTK3-based GUI for cliphist)
+nwg-clipman:
+nwg-clipman: Nwg-clipman is a GTK3-based GUI for Senan Kelly's cliphist. It
+nwg-clipman: provides access to previously copied items, as well as management of
+nwg-clipman: the clipboard history from a window opened on gtk-layer-shell. The
+nwg-clipman: program is intended for use with sway, Hyprland and other
+nwg-clipman: wlroots-based Wayland compositors.
+nwg-clipman:
+nwg-clipman: Homepage: https://github.com/nwg-piotr/nwg-clipman
+nwg-clipman:
+nwg-clipman: