summaryrefslogtreecommitdiffstats
path: root/games/znake
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-02-21 13:26:19 -0500
committer Robby Workman <rworkman@slackbuilds.org>2022-02-21 14:34:28 -0600
commit441a125d5d0fcb85d211a8987e5f7775c1be076b (patch)
tree15dad8fdcffd3588c7305f05f483e8f64d7fb3b1 /games/znake
parent8f7252d8a830c01765221ebe9a11bfcf34c1ddb2 (diff)
downloadslackbuilds-441a125d5d0fcb85d211a8987e5f7775c1be076b.tar.gz
slackbuilds-441a125d5d0fcb85d211a8987e5f7775c1be076b.tar.xz
games/znake: Fix 15.0 build.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'games/znake')
-rw-r--r--games/znake/znake.SlackBuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/games/znake/znake.SlackBuild b/games/znake/znake.SlackBuild
index bf2c7651f2..06c8cfd0c8 100644
--- a/games/znake/znake.SlackBuild
+++ b/games/znake/znake.SlackBuild
@@ -22,6 +22,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220221 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix build on 15.0.
+# - actually use SLKCFLAGS.
+# - binary in /usr/games.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=znake
@@ -38,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,17 +77,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-mkdir -p $PKG/usr/bin
-sed -i "s/usr\/local/usr/" src/Makefile
+mkdir -p $PKG/usr/games
+sed -i -e "s/usr\/local/usr/" \
+ -e "s,-Wall,$SLKCFLAGS -fcommon," \
+ src/Makefile
make
-make install PREFIX=$PKG/usr/bin/
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+make install PREFIX=$PKG/usr/games/
+strip $PKG/usr/games/$PRGNAM
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHOR COPYING ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION