summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-01 06:23:06 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-01 06:50:35 +0700
commite4ae864bddfb4cc5986909841148c4e6e64bed4c (patch)
treefbbf6e5e52028bcd79eaa0472766d4d97b007802 /libraries
parentd3556a43b83f61ff0b32b30f414a4a55a101ba87 (diff)
downloadslackbuilds-e4ae864bddfb4cc5986909841148c4e6e64bed4c.tar.gz
slackbuilds-e4ae864bddfb4cc5986909841148c4e6e64bed4c.tar.xz
libraries/wxPython4: Fixed build on current.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/wxPython4/cython.patch16
-rw-r--r--libraries/wxPython4/wxPython4.SlackBuild6
2 files changed, 20 insertions, 2 deletions
diff --git a/libraries/wxPython4/cython.patch b/libraries/wxPython4/cython.patch
new file mode 100644
index 0000000000..3e1a2a0377
--- /dev/null
+++ b/libraries/wxPython4/cython.patch
@@ -0,0 +1,16 @@
+Fix compatibility with Cython 3.0.0
+Remove unused import which seems to be removed in Cython 3.
+https://github.com/wxWidgets/Phoenix/issues/2439
+https://github.com/wxWidgets/Phoenix/pull/2441
+https://github.com/wxWidgets/Phoenix/issues/2514
+https://github.com/wxWidgets/Phoenix/commit/aeb557d01e7cd37176ebbf0f1ae6d0b53c115378
+--- wx/svg/_nanosvg.pyx.orig
++++ wx/svg/_nanosvg.pyx
+@@ -42,7 +42,6 @@ for manipulating the SVG shape info in memory.
+
+ import sys
+
+-cimport cython.object
+ from cpython.buffer cimport (
+ Py_buffer, PyObject_CheckBuffer, PyObject_GetBuffer, PyBUF_SIMPLE,
+ PyBuffer_Release)
diff --git a/libraries/wxPython4/wxPython4.SlackBuild b/libraries/wxPython4/wxPython4.SlackBuild
index 0bbcbc0f50..ea7862534f 100644
--- a/libraries/wxPython4/wxPython4.SlackBuild
+++ b/libraries/wxPython4/wxPython4.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for wxPython4
-# Copyright 2018-2023 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2018-2024 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wxPython4
SRCNAM=wxPython
VERSION=${VERSION:-4.2.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,6 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+patch -p0 < $CWD/cython.patch
+
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/share/{applications,pixmaps} $PKG/usr/share/icons/hicolor/{16x16,32x32}/apps