summaryrefslogtreecommitdiffstats
path: root/office/kbibtex
diff options
context:
space:
mode:
author ArTourter <artourter@gmail.com>2023-01-29 16:30:27 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-07 07:37:43 +0700
commit7d17655b86aba347470b6eedd205203775c4b0c2 (patch)
tree8934d39a14108c9a61c4715bf217d7ff0b62fdad /office/kbibtex
parent65b388bc0d1d0b863dbd7a4192c1019aa63e1c03 (diff)
downloadslackbuilds-7d17655b86aba347470b6eedd205203775c4b0c2.tar.gz
slackbuilds-7d17655b86aba347470b6eedd205203775c4b0c2.tar.xz
office/kbibtex: Updated for version 0.10.0
- disabled build testing as requires X which doesn't work with sudo anyway and slows down build - Using git repo archive download link as the stable kde downloads links are not permanent - add patch to fix desktop file permissions Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/kbibtex')
-rw-r--r--office/kbibtex/desktop_perms.patch13
-rw-r--r--office/kbibtex/kbibtex.SlackBuild19
-rw-r--r--office/kbibtex/kbibtex.info6
3 files changed, 27 insertions, 11 deletions
diff --git a/office/kbibtex/desktop_perms.patch b/office/kbibtex/desktop_perms.patch
new file mode 100644
index 0000000000..47061964c2
--- /dev/null
+++ b/office/kbibtex/desktop_perms.patch
@@ -0,0 +1,13 @@
+diff --git a/src/program/CMakeLists.txt b/src/program/CMakeLists.txt
+index b9ed670f..8ff76302 100644
+--- a/src/program/CMakeLists.txt
++++ b/src/program/CMakeLists.txt
+@@ -135,7 +135,7 @@ install(
+ )
+
+ install(
+- PROGRAMS
++ FILES
+ org.kde.kbibtex.desktop
+ DESTINATION
+ ${KDE_INSTALL_APPDIR}
diff --git a/office/kbibtex/kbibtex.SlackBuild b/office/kbibtex/kbibtex.SlackBuild
index 60579fb748..5f3ea62116 100644
--- a/office/kbibtex/kbibtex.SlackBuild
+++ b/office/kbibtex/kbibtex.SlackBuild
@@ -1,9 +1,8 @@
#!/bin/bash
-# vim: et ts=2 sw=2
# Slackware build script for kbibtex
-# Copyright (c) 2011-2021 Gregory J. L. Tourte (artourter@gmail.com)
+# Copyright (c) 2011-2023 Gregory J. L. Tourte (artourter@gmail.com)
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,11 +25,13 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=kbibtex
-VERSION=${VERSION:-0.9.90}
+VERSION=${VERSION:-0.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+SRCVER=v$VERSION
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -70,9 +71,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.bz2
+cd $PRGNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,15 +81,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/desktop_perms.patch
+
mkdir -p build
cd build
cmake \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIB_SUFFIX=${LIBDIRSUFFIX} \
-DCMAKE_INSTALL_MANDIR=/usr/man \
-DKDE_INSTALL_DOCBUNDLEDIR=/usr/doc/HTML \
-DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTING=OFF \
-Wno-dev \
..
@@ -102,7 +105,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md LICENSE TODO.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md LICENSE TODO.md ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/office/kbibtex/kbibtex.info b/office/kbibtex/kbibtex.info
index 608636de39..2b6ee7ef86 100644
--- a/office/kbibtex/kbibtex.info
+++ b/office/kbibtex/kbibtex.info
@@ -1,8 +1,8 @@
PRGNAM="kbibtex"
-VERSION="0.9.90"
+VERSION="0.10.0"
HOMEPAGE="https://userbase.kde.org/KBibTeX"
-DOWNLOAD="https://download.kde.org/unstable/KBibTeX/kbibtex-0.9.90.tar.xz"
-MD5SUM="02a5d0305829b057bf2d8bb8f73b1cdf"
+DOWNLOAD="https://invent.kde.org/office/kbibtex/-/archive/v0.10.0/kbibtex-v0.10.0.tar.bz2"
+MD5SUM="4b32d308183cdc88ba4e485c8e4e74b9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""