summaryrefslogtreecommitdiffstats
path: root/office/krop/krop.SlackBuild
diff options
context:
space:
mode:
author Alexander Verbovetsky <alik@ejik.org>2023-06-22 23:08:19 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-22 23:08:19 +0700
commit6ba98e2001995c2d20f9b5203d01206d9270c203 (patch)
tree8dd607870b784c2cb94e3afe2414d0dc986b5743 /office/krop/krop.SlackBuild
parentab68b5de51066bccee9687b81b6a4ac43e5b17bf (diff)
downloadslackbuilds-6ba98e2001995c2d20f9b5203d01206d9270c203.tar.gz
slackbuilds-6ba98e2001995c2d20f9b5203d01206d9270c203.tar.xz
office/krop: Updated for version 0.6.1_e96d42b.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/krop/krop.SlackBuild')
-rw-r--r--office/krop/krop.SlackBuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/office/krop/krop.SlackBuild b/office/krop/krop.SlackBuild
index d1dd7f527c..beeb0c1f6e 100644
--- a/office/krop/krop.SlackBuild
+++ b/office/krop/krop.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for krop
-# Copyright 2018-2020, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2018-2023, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=krop
-VERSION=${VERSION:-0.6.0}
+VERSION=${VERSION:-0.6.1_e96d42b}
+COMMIT="e96d42b2f1ab4317efe37cab498b708663bc104c"
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -69,9 +67,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -82,7 +80,6 @@ find -L . \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
python3 setup.py install --root=$PKG
-sed -i "s|krop==0.6.0|krop|g" $PKG/usr/bin/krop
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true