summaryrefslogtreecommitdiffstats
path: root/office/zathura-ps/zathura-ps.SlackBuild
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2021-08-01 15:12:26 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-13 00:51:25 +0700
commit2ef489c6ca8611485c8f97cdd80f94f8ac7d6970 (patch)
tree29dc3920a66aa64049c6dd92bc180e789026112e /office/zathura-ps/zathura-ps.SlackBuild
parent8eb2d02796c84ff9c790e19cb30041d76708acab (diff)
downloadslackbuilds-2ef489c6ca8611485c8f97cdd80f94f8ac7d6970.tar.gz
slackbuilds-2ef489c6ca8611485c8f97cdd80f94f8ac7d6970.tar.xz
office/zathura-ps: Updated for version 0.2.7.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/zathura-ps/zathura-ps.SlackBuild')
-rw-r--r--office/zathura-ps/zathura-ps.SlackBuild35
1 files changed, 20 insertions, 15 deletions
diff --git a/office/zathura-ps/zathura-ps.SlackBuild b/office/zathura-ps/zathura-ps.SlackBuild
index d9ef5174a3..64a2ae8cf1 100644
--- a/office/zathura-ps/zathura-ps.SlackBuild
+++ b/office/zathura-ps/zathura-ps.SlackBuild
@@ -9,7 +9,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=zathura-ps
-VERSION=${VERSION:-0.2.5}
+VERSION=${VERSION:-0.2.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +22,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -57,17 +54,25 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-sed -i "s,-fPIC,$SLKCFLAGS," config.mk
-
-make
-strip *.so
-make install DESTDIR=$PKG
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS LICENSE $PKG/usr/doc/$PRGNAM-$VERSION