summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python3-seaborn/python3-seaborn.SlackBuild7
-rw-r--r--python/python3-seaborn/python3-seaborn.info8
2 files changed, 8 insertions, 7 deletions
diff --git a/python/python3-seaborn/python3-seaborn.SlackBuild b/python/python3-seaborn/python3-seaborn.SlackBuild
index abb48f95bd..18d9c47811 100644
--- a/python/python3-seaborn/python3-seaborn.SlackBuild
+++ b/python/python3-seaborn/python3-seaborn.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-seaborn
-VERSION=${VERSION:-0.11.2}
+VERSION=${VERSION:-0.12.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,13 +77,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md requirements.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-seaborn/python3-seaborn.info b/python/python3-seaborn/python3-seaborn.info
index 1ce4289eb5..464a5a1eb0 100644
--- a/python/python3-seaborn/python3-seaborn.info
+++ b/python/python3-seaborn/python3-seaborn.info
@@ -1,10 +1,10 @@
PRGNAM="python3-seaborn"
-VERSION="0.11.2"
+VERSION="0.12.1"
HOMEPAGE="https://seaborn.pydata.org/"
-DOWNLOAD="https://github.com/mwaskom/seaborn/archive/v0.11.2/seaborn-0.11.2.tar.gz"
-MD5SUM="2c73097c1c48af26587b65499d559b10"
+DOWNLOAD="https://github.com/mwaskom/seaborn/archive/v0.12.1/seaborn-0.12.1.tar.gz"
+MD5SUM="8f7e319e96f01512b896cae3038b8d67"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-matplotlib python3-pandas scipy3"
+REQUIRES="python3-matplotlib python3-pandas python3-build python3-flit_core"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"