summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--office/krop/README10
-rw-r--r--office/krop/krop.SlackBuild16
-rw-r--r--office/krop/krop.info2
3 files changed, 6 insertions, 22 deletions
diff --git a/office/krop/README b/office/krop/README
index 36345b8eb4..c6c208c595 100644
--- a/office/krop/README
+++ b/office/krop/README
@@ -1,8 +1,8 @@
krop is a simple graphical tool to crop the pages of PDF files.
-It is written in Python and relies on python-poppler-qt5 or PyMuPDF for
-rendering, and pypdf/PyPDF2 or pikepdf or PyMuPDF for cropping. It
-features automatic margin cropping.
+It is written in Python and relies on python-poppler-qt5 or
+python3-PyMuPDF for rendering, and pypdf/python3-PyPDF2 or pikepdf or
+python3-PyMuPDF for cropping. It features automatic margin cropping.
Krop can automatically split pages into subpages to fit the limited
screen size of devices such as eReaders. This is particularly useful, if
@@ -11,6 +11,6 @@ your eReader does not support convenient scrolling.
This script has no build dependencies.
Two runtime dependencies to be choosen from the following options:
-* python-poppler-qt5 or PyMuPDF
-* pypdf (version > 3) or PyPDF2 or pikepdf or PyMuPDF
+* python-poppler-qt5 or python3-PyMuPDF
+* pypdf (version > 3) or python3-PyPDF2 or pikepdf or python3-PyMuPDF
They are autodetected or set manually using options.
diff --git a/office/krop/krop.SlackBuild b/office/krop/krop.SlackBuild
index beeb0c1f6e..b768e7ec12 100644
--- a/office/krop/krop.SlackBuild
+++ b/office/krop/krop.SlackBuild
@@ -48,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,8 +63,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/office/krop/krop.info b/office/krop/krop.info
index 603dbbc217..0410cf1288 100644
--- a/office/krop/krop.info
+++ b/office/krop/krop.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/arminstraub/krop/archive/e96d42b/krop-e96d42b2f1ab4
MD5SUM="9ddb0caa00585882e4d3b081bf5b3b4f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="%README% python-poppler-qt5 PyPDF2"
+REQUIRES="%README% python-poppler-qt5 python3-PyPDF2"
MAINTAINER="Alexander Verbovetsky"
EMAIL="alik@ejik.org"