summaryrefslogtreecommitdiffstats
path: root/academic/cblas/patches/cmake-piecewise.diff
diff options
context:
space:
mode:
Diffstat (limited to 'academic/cblas/patches/cmake-piecewise.diff')
-rw-r--r--academic/cblas/patches/cmake-piecewise.diff12
1 files changed, 6 insertions, 6 deletions
diff --git a/academic/cblas/patches/cmake-piecewise.diff b/academic/cblas/patches/cmake-piecewise.diff
index 13402a52e7..1dc85494a7 100644
--- a/academic/cblas/patches/cmake-piecewise.diff
+++ b/academic/cblas/patches/cmake-piecewise.diff
@@ -160,7 +160,7 @@ deleted file mode 100644
diff --git a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -55,8 +55,6 @@
+@@ -81,8 +81,6 @@
endif()
# --------------------------------------------------
@@ -169,7 +169,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
if (UNIX)
include(GNUInstallDirs)
set(ARCHIVE_DIR ${CMAKE_INSTALL_LIBDIR})
-@@ -70,7 +68,6 @@
+@@ -96,7 +94,6 @@
macro(lapack_install_library lib)
install(TARGETS ${lib}
@@ -177,7 +177,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
ARCHIVE DESTINATION ${ARCHIVE_DIR}
LIBRARY DESTINATION ${LIBRARY_DIR}
RUNTIME DESTINATION ${RUNTIME_DIR}
-@@ -96,20 +93,6 @@
+@@ -122,20 +119,6 @@
include( CheckLAPACKCompilerFlags )
CheckLAPACKCompilerFlags()
@@ -198,7 +198,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
set(PKG_CONFIG_DIR ${LIBRARY_DIR}/pkgconfig)
set(prefix ${CMAKE_INSTALL_PREFIX})
-@@ -120,6 +103,11 @@
+@@ -146,6 +129,11 @@
endif()
# --------------------------------------------------
@@ -210,7 +210,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
# Precision to build
# By default all precisions are generated
option(BUILD_SINGLE "Build Single Precision" ON)
-@@ -150,236 +138,134 @@
+@@ -176,236 +164,134 @@
Please enable at least one of these: BUILD_SINGLE, BUILD_DOUBLE, BUILD_COMPLEX, BUILD_COMPLEX16.")
endif()
@@ -548,7 +548,7 @@ diff --git a/LAPACKE/CMakeLists.txt b/LAPACKE/CMakeLists.txt
-install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/lapacke-config.cmake
- ${LAPACK_BINARY_DIR}/lapacke-config-version.cmake
-- DESTINATION lib/cmake/lapacke-${LAPACK_VERSION}
+- DESTINATION ${LIBRARY_DIR}/cmake/lapacke-${LAPACK_VERSION}
- )
-
-install(EXPORT lapacke-targets