summaryrefslogtreecommitdiffstats
path: root/audio/plug/plug.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/plug/plug.SlackBuild')
-rwxr-xr-x[-rw-r--r--]audio/plug/plug.SlackBuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/audio/plug/plug.SlackBuild b/audio/plug/plug.SlackBuild
index e8a2135ed5..b13b1b9254 100644..100755
--- a/audio/plug/plug.SlackBuild
+++ b/audio/plug/plug.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for plug
-# Copyright 2022 Antonio Leal, Lisbon, Portugal
+# Copyright 2022-2023 Antonio Leal, Porto Salvo, Oeiras, Portugal
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=plug
-VERSION=${VERSION:-1.4.3}
+VERSION=${VERSION:-1.4.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,17 +79,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch CMakeLists.txt $CWD/CMakeLists.txt.patch
mkdir build
cd build
cmake ..
make
-make unittest
+#make unittest
mkdir -p $PKG/usr/bin
cp $BUILDDIR/build/src/plug $PKG/usr/bin
mkdir -p $PKG/lib/udev/rules.d
-cp $BUILDDIR/cmake/50-mustang.rules $PKG/lib/udev/rules.d
+cp $BUILDDIR/cmake/*.rules $PKG/lib/udev/rules.d
mkdir -p $PKG/usr/share/pixmaps
cp $CWD/plug.png $PKG/usr/share/pixmaps
mkdir -p $PKG/usr/share/applications