summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
Diffstat (limited to 'gis')
-rw-r--r--gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild b/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild
index 3a0ac454f0..1e9dffc224 100644
--- a/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild
+++ b/gis/python3-netcdf4-python/python3-netcdf4-python.SlackBuild
@@ -71,7 +71,8 @@ sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
# Requires newer version of setuptools than available in -stable. Has not
# effect on -current
-export PYTHONPATH=/opt/python3.9/site-packages
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl