summaryrefslogtreecommitdiffstats
path: root/office/hunspell-id/hunspell-id.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/hunspell-id/hunspell-id.SlackBuild')
-rw-r--r--office/hunspell-id/hunspell-id.SlackBuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/office/hunspell-id/hunspell-id.SlackBuild b/office/hunspell-id/hunspell-id.SlackBuild
index e27b4a42cb..fbd5d99ff4 100644
--- a/office/hunspell-id/hunspell-id.SlackBuild
+++ b/office/hunspell-id/hunspell-id.SlackBuild
@@ -24,18 +24,20 @@
# Based on the Arch PKGBUILD
+# 20220217 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix download URL.
+# - merge hyphen-id with this build. they install files from the same
+# source archive, there's no reason to have separate builds.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=hunspell-id
VERSION=${VERSION:-2.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH="noarch"
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -55,11 +57,12 @@ rm -rf $PRGNAM-$VERSION
mkdir -p $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
-bsdtar -xf $CWD/id_id.oxt
+unzip $CWD/id-id.oxt '*.dic' info/long-description.txt
# Putting everything in proper place
-install -dm755 $PKG/usr/share/hunspell
+mkdir -p $PKG/usr/share/{hunspell,hyphen}
install -m644 id_ID.* $PKG/usr/share/hunspell
+install -m644 hyph_id_ID.dic $PKG/usr/share/hyphen
# myspell symlinks
install -dm755 $PKG/usr/share/myspell/dicts
@@ -68,6 +71,7 @@ pushd $PKG/usr/share/myspell/dicts
ln -sv ../../hunspell/$(basename $file) .
done
popd
+ln -s ../../hyphen/hyph_id_ID.dic $PKG/usr/share/myspell/dicts
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
install -m644 info/long-description.txt $PKG/usr/doc/$PRGNAM-$VERSION/README.txt