summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Juan M. Lasca <juanmlasca@gmail.com>2023-10-26 21:52:28 +0900
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-28 13:11:51 +0700
commitf04fc84e0d3498c27a346e4b3c91acd359845b3f (patch)
treeac0094cd50ce34c3ad89c93e7773a4193dd3524a
parent53e41de2a9ad3622c010ccbc7a3baadfa0c662ce (diff)
downloadslackbuilds-f04fc84e0d3498c27a346e4b3c91acd359845b3f.tar.gz
slackbuilds-f04fc84e0d3498c27a346e4b3c91acd359845b3f.tar.xz
libraries/libgedit-amtk: Added (Actions, Menus and Toolbars Kit).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/libgedit-amtk/README7
-rw-r--r--libraries/libgedit-amtk/libgedit-amtk.SlackBuild119
-rw-r--r--libraries/libgedit-amtk/libgedit-amtk.info10
-rw-r--r--libraries/libgedit-amtk/slack-desc19
4 files changed, 155 insertions, 0 deletions
diff --git a/libraries/libgedit-amtk/README b/libraries/libgedit-amtk/README
new file mode 100644
index 0000000000..ab9edb9624
--- /dev/null
+++ b/libraries/libgedit-amtk/README
@@ -0,0 +1,7 @@
+Amtk is the acronym for “Actions, Menus and Toolbars Kit”.
+It is a basic GtkUIManager replacement based on GAction
+targetting GTK+ 3.
+
+It is suitable for both a traditional UI or a modern UI
+with a GtkHeaderBar.
+
diff --git a/libraries/libgedit-amtk/libgedit-amtk.SlackBuild b/libraries/libgedit-amtk/libgedit-amtk.SlackBuild
new file mode 100644
index 0000000000..3a1cf414e4
--- /dev/null
+++ b/libraries/libgedit-amtk/libgedit-amtk.SlackBuild
@@ -0,0 +1,119 @@
+#!/bin/bash
+
+# Slackware build script for libgedit-amtk
+
+# Copyright 2010,2011 Robby Workman, Northport, Alabama, USA
+# Copyright 2011 byteframe
+# Maintained 2020, 2021, 2022 by Donald Cooley <chytraeu@sdf.org>
+# Copyright 2022 Juan M. Lasca <juanmlasca@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Special thanks to Brandon Pribula, who kindly handed over maintenance to me.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=libgedit-amtk
+VERSION=${VERSION:-5.8.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# circunvent meson version mismtach (fs.copyfile not available)
+# and also avoid gtk_doc, which uses fs.copyfile
+sed -i "s/meson_version: '>= 0.64'/meson_version: '>= 0.59'/" meson.build
+
+# minor change: use default Gio.ApplicationFlags value upto version 2.74
+sed -i 's/G_APPLICATION_DEFAULT_FLAGS/G_APPLICATION_FLAGS_NONE/' \
+ tests/interactive-tests/{test-headerbar,test-traditional-ui}.c
+
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dgtk_doc=false \
+ -Dstrip=true
+"${NINJA:=ninja}"
+DESTDIR=$PKG $NINJA install
+cd ..
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.md NEWS LICENSES/LGPL-3.0-or-later.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/libgedit-amtk/libgedit-amtk.info b/libraries/libgedit-amtk/libgedit-amtk.info
new file mode 100644
index 0000000000..99a97cb69a
--- /dev/null
+++ b/libraries/libgedit-amtk/libgedit-amtk.info
@@ -0,0 +1,10 @@
+PRGNAM="libgedit-amtk"
+VERSION="5.8.0"
+HOMEPAGE="https://gedit-technology.net/"
+DOWNLOAD="https://gedit-technology.net/tarballs/libgedit-amtk/libgedit-amtk-5.8.0.tar.xz"
+MD5SUM="1b2ad96c189dd1749b6526c6026e0618"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Juan M. Lasca"
+EMAIL="juanmlasca@gmail.com"
diff --git a/libraries/libgedit-amtk/slack-desc b/libraries/libgedit-amtk/slack-desc
new file mode 100644
index 0000000000..21104bb934
--- /dev/null
+++ b/libraries/libgedit-amtk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libgedit-amtk: libgedit-amtk (Actions, Menus and Toolbars Kit)
+libgedit-amtk:
+libgedit-amtk: It is a basic GtkUIManager replacement based on GAction
+libgedit-amtk: targetting GTK+ 3.
+libgedit-amtk: It is suitable for both a traditional UI or a modern UI
+libgedit-amtk: with a GtkHeaderBar.
+libgedit-amtk:
+libgedit-amtk:
+libgedit-amtk:
+libgedit-amtk: for more info see: https://gedit-technology.net/
+libgedit-amtk: