summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Antonio Leal <antonio.leal@yahoo.com>2024-01-20 17:12:56 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-21 00:20:16 +0700
commit9b65a74ecb2001830c0716ef357db388915fdea1 (patch)
tree941e4b4309e9a572308613aa33bab971f941e498 /audio
parentf38b4f0a4f7f28ced7df2549f887100466561b4a (diff)
downloadslackbuilds-9b65a74ecb2001830c0716ef357db388915fdea1.tar.gz
slackbuilds-9b65a74ecb2001830c0716ef357db388915fdea1.tar.xz
audio/plug: Updated for version 1.4.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/plug/CMakeLists.txt.patch11
-rwxr-xr-x[-rw-r--r--]audio/plug/plug.SlackBuild9
-rw-r--r--audio/plug/plug.info8
3 files changed, 20 insertions, 8 deletions
diff --git a/audio/plug/CMakeLists.txt.patch b/audio/plug/CMakeLists.txt.patch
new file mode 100644
index 0000000000..5be4e0e60e
--- /dev/null
+++ b/audio/plug/CMakeLists.txt.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt 2023-12-03 14:22:05.000000000 +0000
++++ CMakeLists.txt.new 2023-12-04 22:05:56.210467471 +0000
+@@ -4,7 +4,7 @@
+ message(STATUS "~~~ ${PROJECT_NAME} v${PROJECT_VERSION} ~~~")
+
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+-option(PLUG_UNITTEST "Build Unit Tests" ON)
++option(PLUG_UNITTEST "Build Unit Tests" OFF)
+ message(STATUS "Unit Tests : ${PLUG_UNITTEST}")
+
+ option(PLUG_COVERAGE "Enable Coverage" OFF)
diff --git a/audio/plug/plug.SlackBuild b/audio/plug/plug.SlackBuild
index e8a2135ed5..b13b1b9254 100644..100755
--- a/audio/plug/plug.SlackBuild
+++ b/audio/plug/plug.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for plug
-# Copyright 2022 Antonio Leal, Lisbon, Portugal
+# Copyright 2022-2023 Antonio Leal, Porto Salvo, Oeiras, Portugal
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=plug
-VERSION=${VERSION:-1.4.3}
+VERSION=${VERSION:-1.4.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,17 +79,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch CMakeLists.txt $CWD/CMakeLists.txt.patch
mkdir build
cd build
cmake ..
make
-make unittest
+#make unittest
mkdir -p $PKG/usr/bin
cp $BUILDDIR/build/src/plug $PKG/usr/bin
mkdir -p $PKG/lib/udev/rules.d
-cp $BUILDDIR/cmake/50-mustang.rules $PKG/lib/udev/rules.d
+cp $BUILDDIR/cmake/*.rules $PKG/lib/udev/rules.d
mkdir -p $PKG/usr/share/pixmaps
cp $CWD/plug.png $PKG/usr/share/pixmaps
mkdir -p $PKG/usr/share/applications
diff --git a/audio/plug/plug.info b/audio/plug/plug.info
index 266f94d1e5..0fe67adca4 100644
--- a/audio/plug/plug.info
+++ b/audio/plug/plug.info
@@ -1,10 +1,10 @@
PRGNAM="plug"
-VERSION="1.4.3"
+VERSION="1.4.5"
HOMEPAGE="https://github.com/offa/plug"
-DOWNLOAD="https://github.com/offa/plug/archive/v1.4.3/plug-1.4.3.tar.gz"
-MD5SUM="69b7dfffaecc0ceec038267ae9981750"
+DOWNLOAD="https://github.com/offa/plug/archive/v1.4.5/plug-1.4.5.tar.gz"
+MD5SUM="c86d1dc7f4c44a8247199eaf3b6c448b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="gtest"
+REQUIRES=""
MAINTAINER="Antonio Leal"
EMAIL="antonioleal@yahoo.com"